D - Danganronpa

Chisa Yukizome works as a teacher in the school. She prepares many gifts, which consist of nn kinds with a[i]a[i] quantities of each kind, for her students and wants to hold a class meeting. Because of the busy work, she gives her gifts to the monitor, Chiaki Nanami. Due to the strange design of the school, the students' desks are in a row. Chiaki Nanami wants to arrange gifts like this: 

1. Each table will be prepared for a mysterious gift and an ordinary gift. 

2. In order to reflect the Chisa Yukizome's generosity, the kinds of the ordinary gift on the adjacent table must be different. 

3. There are no limits for the mysterious gift. 

4. The gift must be placed continuously. 

She wants to know how many students can get gifts in accordance with her idea at most (Suppose the number of students are infinite). As the most important people of her, you are easy to solve it, aren't you?

Input

The first line of input contains an integer T(T≤10)T(T≤10) indicating the number of test cases. 

Each case contains one integer nn. The next line contains nn (1≤n≤10)(1≤n≤10) numbers: a1,a2,...,ana1,a2,...,an, (1≤ai≤100000)(1≤ai≤100000).

Output

For each test case, output one line containing “Case #x: y” (without quotes) , where x is the test case number (starting from 1) and y is the answer of Chiaki Nanami's question.

Sample Input

1
2
3 2

Sample Output

Case #1: 2

题意: 
有n种礼物,每种礼物分别有a[i]种。这些礼物可以当做神秘礼物,也可以当做普通礼物来使用。现在要在一些连续的桌子上摆放礼物,摆放的要求是: 
1.每个桌子必须有一个神秘礼物和一个普通礼物 
2.相邻的两个桌子的普通礼物不能相同 
3.神秘礼物不做要求

问最多能摆放多少个桌子。

解题思路: 
首先每种方案的最大值为 sum/2。 
对于其他方案的贪心做法: 
将种类数最多的礼物间隔放,然后其他的礼物放在间隔处。

#include <iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int main()
{
    int t;
    int p=0;
    cin>>t;
    while(t--)
    {
        p++;
        int n;
        int ans=0;
        int sum=0;
        cin>>n;
        for(int i=1; i<=n; i++)
        {
            int x;
            cin>>x;
            ans+=x;
            sum=max(sum,x);
        }
        printf("Case #%d: ",p);
        printf("%d\n",min(ans/2,(ans-sum)*2+1));
    }
    return 0;
}
 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值