The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
Sample Input
2 3 5 7 15 6 4 10296 936 1287 792 1
Sample Output
105 10296
#include <iostream>
#include<stdio.h>
#include<string>
using namespace std;
int st(int a,int b)
{
if(a%b==0)return b;
else return st(b,(a%b));
}
int main()
{
int t;
cin>>t;
while(t--)
{
int n;
cin>>n;
long long int sum=1;
while(n--)
{
long long int x;
scanf("%lld",&x);
sum=(sum*x)/st(sum,x);
}
printf("%lld\n",sum);
}
return 0;
}