E - Find The Multiple(DFS)(18.9.13)

E - Find The Multiple

Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Submit Status

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

 

Sample Output

10
100100100100100100
111111111111111111

 

题意:给出一个数n,然后求得一个数字k,数字满足:能被n整除,每一位只有0,1。这样的数字k会有很多个,然以输出一个就可以。

思路:n的最大值为200,用dfs从数字k的个位开始往高位搜索,每一位只有0或1。找到能被n整除的时候输出就可以了。

ps:(一开始不知道到底应该搜到多少位时可以return,后来看到网上说最多到19位就可以)

代码如下:

#include <iostream>
#include <string>
#include <cstring>
#include<stdio.h>
using namespace std;
int n,flas;
void dfs(int k,long long cur)//k:位数 cur:当前数字
{
    if(k==19||flas)
        return;
    if(cur%n==0)
    {
        cout<<cur<<endl;
        flas=1;
        return;
    }
    dfs(k+1,cur*10);//高位为 0
    dfs(k+1,cur*10+1);//高位为 1
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {

        if(n==0)break;
        flas=0;
        dfs(0,1);
    }
    return 0;
}

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值