C - Heavy Transportation(18.9.18)

Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

题意:要从城市1到城市N运送货物,有M条道路,每条道路都有它的最大载重量,问从城市1到城市N运送最多的重量是多少。

其实题意很简单,就是找一条1-->N的路径,在不超过每条路径的最大载重量的情况下,使得运送的货物最多。一条路径上的最大

载重量为这个路径上权值最小的边;

思路:dijkstra 的变形,我们只需要每次选取离源点载货量最多的那条边,然后通过它去松弛所有路径上的最大载重量;

说一下为什么要每次选取离源点权值最大的那个点去松弛,我们知道原始的dijkstra是每次选取离源点最近的边去松弛使得求出的源

点到其余点的单源最短路径最短,那么我们这里希望让它路径上权值最小的边尽可能的大,我们就需要去选取离源点权值最大的点,使

得它的该路径的最大载重量大一些;

#include <cstdio>
#include <iostream>
#include <cstdlib>
#include <algorithm>
#include <string.h>
#include <cmath>
using namespace std;
const int N=1005;
const int inf=0x3f3f3f3f;
int n,m;
int mp[N][N];
int vis[N];
int dijkstra()
{
    int v,mi;
    int d[N];
    for(int i=1; i<=n; i++)
    {
        d[i]=mp[1][i];
    }
    for(int i=1; i<=n; i++)
    {
        mi=-1;
        for(int j=1; j<=n; j++)
        {

            if(!vis[j]&&d[j]>mi)
            {
                mi=d[j];
                v=j;
            }
//这里需要每次选取离源点权值最大的边去松弛;使得最大载重量尽可能的大;
        }
        vis[v]=1;
        for(int j=1; j<=n; j++)
        {
            if(!vis[j]&&d[j]<min(mp[v][j],d[v]))
                d[j]=min(d[v],mp[v][j]);
/*又是比较绕的地方,这里是要选取每条路径中最小的权值作为该路径的最大载重量,
我们又要找路径中最大载重量最大是多少,
所以此时dis数组中保存的为源点到该点的最大载重量*/
        }
    }

    return d[n];
}
int main()
{
    int t;
    int f=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        memset(mp,0,sizeof(mp));
        memset(vis,0,sizeof(vis));

        for(int i=1; i<=m; i++)
        {  int b,c,a;
            scanf("%d%d%d",&a,&b,&c);
            mp[a][b]=mp[b][a]=c;
        }
        printf("Scenario #%d:\n",f++);
        printf("%d\n\n",dijkstra());
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值