嗯 还是 暴

Problem Description
Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".
 

Input
each test case contains two numbers A and B.
 

Output
for each case, if A is equal to B, you should print "YES", or print "NO".
 

Sample Input
  
  
1 2 2 2 3 3 4 3
 

Sample Output
  
  
NO YES YES
NO

#include<stdio.h>
#include<string.h>
int main()
{
    char a[900000],b[900000];
    int i,x,z,t,l,n,j,y;
    for(i=0;i<n;i++)
    {
        a[i]=b[i]='0';
    }
    while(scanf("%s%s",a,b)!=EOF)
    {
        x=0;
        t=strlen(a);
        l=strlen(b);
        if(t>l)
        n=t;
        else
        n=l;
        for(i=0;i<n;i++)
        {
            if(a[i]!=b[i]&&(a[i]!='.'&&b[i]!='.'))
            x=1;
            if(a[i]=='.'||b[i]=='.')
            {
               i=i+1;
               y=n;
               z=n;
               for(j=n-1;j>=i;j--)
               {
                   if(a[j]==0)
                   y--;
                   if(b[j]==0)
                   z--;
               }
               if(z>y)
               n=y;
               else
               n=z;
               for(j=i;j<n;j++)
               {
                   if(a[j]!=b[j])
                   x=1;
                }
                break;    
            }
        }
        if(x)
        printf("NO\n");
        else
        printf("YES\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值