打印沙漏

 
 
*****
*** * *** *****

输入样例:

19 *
输出样例:
 
 
***** *** * *** ***** 2
解:
*****   L3=3 n3=5
***    L2=2 n2=3
  * L1=1 n1=1 *** *****
上沙漏 n=2L-1 上沙漏总数N1=L^2 N(总符号数)=2*L^2-1
#include <stdio.h>  
#include <math.h>  
int count(double n){
    if (n==0||n==1)
		return 0;
	else  
		return n-2*((int)sqrt((n+1)/2))*((int)sqrt((n+1)/2))+1;/*多余的符号数*/
}

	
int main()
{   float n;
    char ch;
    scanf("%f %c",&n,&ch);/*输入符号数和符号*/
	printf("%d\n",count(n));/*输出符号余数*/
	int L=(int)sqrt((n-count(n)+1)/2),i,q,p;/*L上沙漏层数*/
	for (i=L;i>=1;i--)/*上沙漏循环*/
	{   
		for(p=1;p<=L-i;p++)/*输出符号前的空格*/
		printf(" ");
		for(q=2*i-1;q>=1;q--)/*输出符号*/
		{
			printf("%c",ch);
		}
		printf("\n");/*换行*/
		
	}
		for (i=2;i<=L;i++)/*下沙漏循环*/
	{   
		for(p=1;p<=L-i;p++)/*下沙漏空格*/
		printf(" ");
		for(q=1;q<=2*i-1;q++)/*下沙漏符号*/
		{
			printf("%c",ch);
		}
		printf("\n");/*换行*/
		
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值