HDU-5015 233 Matrix 矩阵快速幂

HDU-5015 矩阵快速幂模板题

In our daily life we often use 233 to express our feelings. Actually, we may say 2333, 23333, or 233333 … in the same meaning. And here is the question: Suppose we have a matrix called 233 matrix. In the first line, it would be 233, 2333, 23333… (it means a 0,1 = 233,a 0,2 = 2333,a 0,3 = 23333…) Besides, in 233 matrix, we got a i,j = a i-1,j +a i,j-1( i,j ≠ 0). Now you have known a 1,0,a 2,0,…,a n,0, could you tell me a n,m in the 233 matrix?
Input
There are multiple test cases. Please process till EOF.

For each case, the first line contains two postive integers n,m(n ≤ 10,m ≤ 10 9). The second line contains n integers, a 1,0,a 2,0,…,a n,0(0 ≤ a i,0 < 2 31).
Output
For each case, output a n,m mod 10000007.
Sample Input
1 1
1
2 2
0 0
3 7
23 47 16
Sample Output
234
2799
72937

在这里插入图片描述
**

思路:

**

第一列元素为:

0

a1

a2

a3

a4

转化为:

23

a1

a2

a3

a4

3

则第二列为:

23*10+3

23*10+3+a1

23*10+3+a1+a2

23*10+3+a1+a2+a3

23*10+3+a1+a2+a3+a4

3
在这里插入图片描述

根据前后两列的递推关系,有等式可得矩阵A的元素为:

嗯,然后跑矩阵快速幂就好了,这里的递推公式是一列一列的来,这个得理清楚。

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<cstring>
#define mt(a) memset(a,0,sizeof(a))
using namespace std;
typedef long long ll;
const ll mod=10000007;
struct node{
	ll mp[20][20];
	ll r,c;
};
//矩阵乘法 
node mul(node a,node b){
	ll r=a.r;
	ll c=b.c;
	node temp;
	temp.r=r;
	temp.c=c;
	for(int i=0;i<r;i++){
		for(int j=0;j<c;j++){
			temp.mp[i][j]=0;
			for(int k=0;k<r;k++)
			    temp.mp[i][j]=(a.mp[i][k]*b.mp[k][j]%mod+temp.mp[i][j])%mod;
		}
	} 
	return temp;
}
ll temp[20];
ll n,m;
//矩阵快速幂 
int pow(node a,int k){
	node ans;
	ans.r=n+2;
	ans.c=1;
	memset(ans.mp,0,sizeof(ans.mp));
    ans.mp[0][0]=23;
    for(int i=1;i<=n;i++)
        ans.mp[i][0]=temp[i];
	ans.mp[n+1][0]=3;
	while(k){
		if(k&1)
		    ans=mul(a,ans);
		k/=2;
		a=mul(a,a);
	} 
	return ans.mp[n][0]%mod;
}
int main(){
	while(~scanf("%lld %lld",&n,&m)){
		node a;
		memset(temp,0,sizeof(temp));
		for(int i=1;i<=n;i++)
		    cin>>temp[i];
		if(n==0){
			cout<<temp[m]%mod<<endl;
			continue;
		}
		a.r=n+2;
		a.c=n+2;
		memset(a.mp,0,sizeof(a.mp));
		a.mp[0][0]=10;
		a.mp[0][n+1]=1;
		for(int i=1;i<=n;i++){
			a.mp[i][0]=10;
			a.mp[i][n+1]=1;
			for(int j=1;j<=i;j++)
			   a.mp[i][j]=1;
		}
		a.mp[n+1][n+1]=1;
		ll key=pow(a,m);
		cout<<key<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值