hdu 5015 233 Matrix(最快的搞法)

233 Matrix

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 191    Accepted Submission(s): 125


Problem Description
In our daily life we often use 233 to express our feelings. Actually, we may say 2333, 23333, or 233333 ... in the same meaning. And here is the question: Suppose we have a matrix called 233 matrix. In the first line, it would be 233, 2333, 23333... (it means a 0,1 = 233,a 0,2 = 2333,a 0,3 = 23333...) Besides, in 233 matrix, we got a i,j = a i-1,j +a i,j-1( i,j ≠ 0). Now you have known a 1,0,a 2,0,...,a n,0, could you tell me a n,m in the 233 matrix?
 

Input
There are multiple test cases. Please process till EOF.

For each case, the first line contains two postive integers n,m(n ≤ 10,m ≤ 10 9). The second line contains n integers, a 1,0,a 2,0,...,a n,0(0 ≤ a i,0 < 2 31).
 

Output
For each case, output a n,m mod 10000007.
 

Sample Input
  
  
1 1 1 2 2 0 0 3 7 23 47 16
 

Sample Output
  
  
234 2799 72937
Hint
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5017  5016  5014  5013  5012 
 

解释在代码里:


#include<cstdio>
#define MOD 10000007
using namespace std;
typedef long long LL;
#define rep(i,a,b) for(int i=a;i<b;i++)
LL inv[11]; ///逆元
LL inv_fac[11]; ///阶乘逆元
LL n,m,a[11],tmp;
/**
经过模拟之后发现ans=c(m,0)*a[n-1]+c(m+1,1)*a[n-2]+...c(m+n,n)*a[0]+c(n,0)*(23333...)+
c(n+1,1)*(2333...)+c(n+m-2,m-1)*233;
变形如下:
ans=c(m,0)*a[n-1]+c(m+1,1)*a[n-2]+...c(m+n,n)*a[0]+c(n,n)*(23333...)+
c(n+1,n)*(2333...)+c(n+m-2,n)*233;

ans=c(m,0)*a[n-1]+c(m+1,1)*a[n-2]+...c(m+n,n)*a[0]+{c(n,n)+
c(n+1,n)+c(n+m-2,n)}*233+2100*{10^(m-2)*c(n,n)+10^(m-3)*c(n+1,n)+10^0*c(n+m-4,n)};

ans=c(m,0)*a[n-1]+c(m+1,1)*a[n-2]+...c(m+n,n)*a[0]+c(n+m-1,n)*233
+2100*{10^(m-2)*c(n,n)+10^(m-3)*c(n+1,n)+10^0*c(n+m-4,n)};
设f(n)={10^(m-2)*c(n,n)+10^(m-3)*c(n+1,n)+10^0*c(n+m-4,n)},则有f(n)=((10*f(n-1)-c(n+m-2,n))/9)%MOD;
即f(n)=(10*f(n-1)-c(n+m-2,n))*inv[9]%MOD;
**/
void Init()///初始化数组
{
    int i;
    inv[0]=inv[1]=1;
    inv_fac[0]=inv_fac[1]=1;
    for(i=2;i<15;i++){
            inv[i]=(inv[MOD%i]*(MOD-MOD/i))%MOD;///递推求逆元
            inv_fac[i]=(inv_fac[i-1]*inv[i])%MOD;///递推求阶乘的逆元
    }
}

LL C(LL N,LL k)///计算组合数
{
    if(k==0)return 1;
    LL i,ans=inv_fac[k];
    for(i=0;i<k;i++)
        ans=ans*(N-i)%MOD;
    return ans;
}

LL quick_mod(LL x,LL N)///快速幂取模
{
    LL temp=x%MOD,result=1;
    while(N)
    {
        if(N&1)
            result=result*temp%MOD;
        temp=temp*temp%MOD;
        N>>=1;
    }
    return result;
}

LL f(LL N)
{
    if(N==0)
        return (tmp-1+MOD)*inv[9]%MOD;///用到了等比数列求和sum[n]=a1(1-q^n)/(1-q);
    return (10*f(N-1)-C(N+m-2,N))*inv[9]%MOD;
}
void solve()
{
    if(n==0&&m==0)
    {
        puts("0");
        return;
    }
    tmp=quick_mod(10,m-1);

    LL ans=(C(n+m-1,n)*233+f(n)*2100)%MOD;///第一行的和乘组合数
    int i;
    for(i=1;i<=n;i++)
        ans=(ans+C(n+m-1-i,n-i)*a[i-1])%MOD;///加上第一列的和乘组合数
    printf("%I64d\n",ans);
}
int main()
{
    Init();
    while(~scanf("%I64d%I64d",&n,&m))
    {
        rep(i,0,n){
            scanf("%I64d",&a[i]);
            a[i]%=MOD;
        }
        solve();
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 5
    评论
评论 5
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值