PAT (Advanced Level) Practice 1143 Lowest Common Ancestor

题目描述

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:
For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found…

Sample Input:
6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99
Sample Output:
LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

题意

给出一颗二叉搜索树的前序遍历序列,求任意两个节点的LCA。

思路

直接通过前序序列去建立二叉搜索树会超时,因为极端的情况下的时间复杂度会达到N^2。
所以我们可以通过前序和中序序列去建造树,二叉搜索树的中序序列其实就是前序序列升序排序的序列。
建完树之后,就需要找LCA了。
找LCA我是用的暴力的方法,即先将两个节点调到同一高度,之后再共同向上找LCA。
注意特殊情况,如果x等于y的话,则输出x is an ancestor of x 这样的形式。

代码如下

#include <bits/stdc++.h>
using namespace std;
const int maxm=1005;
const int maxn=10005;
int n,m;
struct tree
{
    int left,right;
    int fa;
    int dep;
    int val;
};
int pre[maxn];
int in[maxn];
tree t[maxn];
int num=0;
int root=-1;
map<int,int>ma;
int build(int pre_left,int pre_right,int in_left,int in_right,int fa,int dep)
{
    if(pre_left>pre_right) return -1;
    //printf("pre=%d in=%d\n",pre_right-pre_left,in_right-in_left);
    int val=pre[pre_left];
    ma[val]=num;
    t[num].val=val;
    t[num].fa=fa;
    t[num].dep=dep;
    int loc=-1;
    int tnum=num;
    for (int i=in_left;i<=in_right;i++)
    {
        if(in[i]==val)
        {
            loc=i;
            break;
        }
    }
    num++;
    t[tnum].left=build(pre_left+1,pre_left+loc-in_left,in_left,loc-1,tnum,dep+1);
    t[tnum].right=build(pre_left+loc-in_left+1,pre_right,loc+1,in_right,tnum,dep+1);
    return tnum;
}
//调到同一高度后找lca
void lca(int inx,int iny,int x,int y)
{
     while(inx!=iny)
    {
        inx=t[inx].fa;
        iny=t[iny].fa;
    }
    printf("LCA of %d and %d is %d.\n",x,y,t[inx].val);
}
//使两个节点处在同一高度
int reach_same(int inx,int iny)
{

    while(t[inx].dep>t[iny].dep)
    {
        inx=t[inx].fa;
    }
    return inx;
}
int main()
{
    memset (t,-1,sizeof(t));
    scanf("%d%d",&m,&n);
    for (int i=0;i<n;i++)
    {
        scanf("%d",&pre[i]);
        in[i]=pre[i];
    }
    sort(in,in+n);
    root=build(0,n-1,0,n-1,-1,0);
    for (int i=0;i<m;i++)
    {
        int x,y;
        scanf("%d%d",&x,&y);
        if(ma.find(x)==ma.end()&&ma.find(y)==ma.end())
        {
            printf("ERROR: %d and %d are not found.\n",x,y);
        }
        else if(ma.find(x)==ma.end())
        {
            printf("ERROR: %d is not found.\n",x);
        }
        else if(ma.find(y)==ma.end())
        {
            printf("ERROR: %d is not found.\n",y);
        }
        else
        {
            if(n==1)
            {
                printf("%d is an ancestor of %d.\n",in[0],in[0]);
                continue;
            }
            int inx=ma[x],iny=ma[y];
            int dx=t[inx].dep,dy=t[iny].dep;
            if(dx==dy)
            {
                lca(inx,iny,x,y);
            }
            else
            {
                if(dx>dy)
                {
                    inx=reach_same(inx,iny);
                    if(inx==iny)
                    {
                        printf("%d is an ancestor of %d.\n",y,x);
                    }
                    else
                    {
                        lca(inx,iny,x,y);
                    }
                }
                else
                {
                    iny=reach_same(iny,inx);
                    if(inx==iny)
                    {
                        printf("%d is an ancestor of %d.\n",x,y);
                    }
                    else
                    {
                        lca(inx,iny,x,y);
                    }
                }
            }
        }

    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
以下是C#中二叉树的lowest common ancestor的源代码: ```csharp using System; public class Node { public int value; public Node left; public Node right; public Node(int value) { this.value = value; this.left = null; this.right = null; } } public class BinaryTree { public Node root; public BinaryTree() { this.root = null; } public Node LowestCommonAncestor(Node node, int value1, int value2) { if (node == null) { return null; } if (node.value == value1 || node.value == value2) { return node; } Node left = LowestCommonAncestor(node.left, value1, value2); Node right = LowestCommonAncestor(node.right, value1, value2); if (left != null && right != null) { return node; } return (left != null) ? left : right; } } public class Program { public static void Main() { BinaryTree tree = new BinaryTree(); tree.root = new Node(1); tree.root.left = new Node(2); tree.root.right = new Node(3); tree.root.left.left = new Node(4); tree.root.left.right = new Node(5); tree.root.right.left = new Node(6); tree.root.right.right = new Node(7); Node lca = tree.LowestCommonAncestor(tree.root, 4, 5); Console.WriteLine("Lowest Common Ancestor of 4 and 5: " + lca.value); lca = tree.LowestCommonAncestor(tree.root, 4, 6); Console.WriteLine("Lowest Common Ancestor of 4 and 6: " + lca.value); lca = tree.LowestCommonAncestor(tree.root, 3, 4); Console.WriteLine("Lowest Common Ancestor of 3 and 4: " + lca.value); lca = tree.LowestCommonAncestor(tree.root, 2, 4); Console.WriteLine("Lowest Common Ancestor of 2 and 4: " + lca.value); } } ``` 在上面的代码中,我们定义了一个Node类和一个BinaryTree类。我们使用BinaryTree类来创建二叉树,并实现了一个LowestCommonAncestor方法来计算二叉树中给定两个节点的最近公共祖先。 在LowestCommonAncestor方法中,我们首先检查给定节点是否为null或与给定值之一匹配。如果是,则返回该节点。否则,我们递归地在左子树和右子树上调用LowestCommonAncestor方法,并检查它们的返回值。如果左子树和右子树的返回值都不为null,则当前节点是它们的最近公共祖先。否则,我们返回非null的那个子树的返回值。 在Main方法中,我们创建了一个二叉树,并测试了LowestCommonAncestor方法的几个不同输入。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值