HDU 1272 小希的迷宫 并查集

上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8。

Input

输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。
整个文件以两个-1结尾。

Output

对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出"Yes",否则输出"No"。

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0

-1 -1

Sample Output

Yes
Yes
No

此题可以用并查集来做,要注意自环的情况是错误的。

当没有自环并且边数+1等于顶点数的话(这里的边数不加自环和两个顶点有同一个父节点的边)输出Yes

此题更坑的是0,0的时候是Yes

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <string>
#include <map>
int is[100005];
int re[100005];
int isis;
using namespace std;
int main()
{
    int temp1,temp2;
    while(scanf("%d%d",&temp1,&temp2)!=EOF&&(temp1!=-1||temp2!=-1))
    {
        if(temp1==0&&temp2==0)
            {
                printf("Yes\n");
                continue;
            }
        int num=0,numb=0;
        isis=0;
        memset (is,0,sizeof(is));
        memset (re,-1,sizeof(re));
        is[temp1]=1;
        is[temp2]=1;
        if(temp1==temp2)
        {
            isis=1;
            re[temp1]=temp1;
        }
        else
            {
                re[temp1]=temp2;
                numb++;
            }
        while (scanf("%d%d",&temp1,&temp2)!=EOF&&(temp1||temp2))
        {
            is[temp1]=1; is[temp2]=1;
            int tt1=temp1,tt2=temp2;
            while (re[tt1]!=-1)
            {
                tt1=re[tt1];
            }
            while (re[tt2]!=-1)
            {
                tt2=re[tt2];
            }
            if(tt1==temp1&&tt2==temp2&&tt1==tt2)
            {
                isis=1;
            }
            else if(tt1==temp1&&tt2==temp2&&tt1!=tt2)
            {
                re[temp1]=temp2;
                numb++;
            }
            else if(tt1==temp1&&tt2!=temp2)
            {
                re[tt1]=temp2;
                numb++;
            }
            else if(tt2==temp2&&tt1!=temp1)
            {
                re[tt2]=temp1;
                numb++;
            }
            else if(tt1!=temp1&&tt2!=temp2)
            {
                if(tt1!=tt2)
                {
                    re[tt1]=tt2;
                    numb++;
                }
                else
                {
                    isis=1;
                }
            }

        }
        for (int i=1;i<=100005;i++)
            if(is[i])
               num++;
        if(!isis&&num==numb+1)
            printf("Yes\n");
        else
            printf("No\n");

    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值