POJ 1724 ROADS

N cities named with numbers 1 ... N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins).
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash.

We want to help Bob to find the shortest path from the city 1 to the city N that he can afford with the amount of money he has.

Input

The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way.
The second line contains the integer N, 2 <= N <= 100, the total number of cities.

The third line contains the integer R, 1 <= R <= 10000, the total number of roads.

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters :

  • S is the source city, 1 <= S <= N
  • D is the destination city, 1 <= D <= N
  • L is the road length, 1 <= L <= 100
  • T is the toll (expressed in the number of coins), 0 <= T <=100


Notice that different roads may have the same source and destination cities.

Output

The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins.
If such path does not exist, only number -1 should be written to the output.

Sample Input

5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2

Sample Output

11

题意的意思就是花费不超过K枚硬币的前提下, 从1走到N城市。

我当时想了一下, 决定用bfs,但是写完之后发现并不对,因为只有裸的bfs是只搜索一次的。

然后决定遍历所有的情况, 于是乎决定用dfs。

这个题必须用邻接表来储存边数, 邻接矩阵行不通。因为这个题目说, 两个城市之间有很多条路径, 邻接矩阵行不通。

代码如下:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <queue>
#include <limits>
using namespace std;
int k;
int cnum,rnum;
int vis[105];
//int minn[105];
int minn;
int flag=0;
struct  edge
{
    int len;
    int cost;
    int city;
    struct edge* next;
};
struct  ver
{
   struct edge* fir;
};
ver v[105];
void dfs (int loc,int llen,int ccost)
{
     if(ccost>k)
        return;
     if(minn<llen)
        return;
     if(loc==cnum)
     {
         minn=min(minn,llen);
         flag=1;
     }
     edge * etemp=v[loc].fir;
     while (etemp!=NULL)
     {
         if(!vis[etemp->city])
         {
             vis[etemp->city]=1;
             dfs(etemp->city,llen+etemp->len,ccost+etemp->cost);
             vis[etemp->city]=0;
         }
         etemp=etemp->next;
     }
}
int main()
{
    for (int i=0;i<105;i++)
           v[i].fir=NULL;
    flag=0;
    minn=2147483647;
    memset (vis,0,sizeof(vis));
    scanf("%d",&k);
    scanf("%d%d",&cnum,&rnum);
    for (int i=0;i<rnum;i++)
    {
        int s,e,len,ccost;
        scanf("%d%d%d%d",&s,&e,&len,&ccost);
        edge * ee=(edge*)malloc(sizeof(edge));
        ee->city=e;
        ee->len=len;
        ee->cost=ccost;
        ee->next=v[s].fir;
        v[s].fir=ee;

    }
    dfs(1,0,0);
        if(flag)
            printf("%d\n",minn);
        else
            printf("-1\n");


}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值