PAT (Advanced Level) Practice 1107 Social Clusters (30 分)并查集

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K​i​​: h​i​​[1] h​i​​[2] ... h​i​​[K​i​​]

where K​i​​ (>0) is the number of hobbies, and h​i​​[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

 题意:
给出每个人的爱好,如果两个人的爱好其中有一项相同,则他们为同一个类,求一共有几个不同的类,并输出每个类的人数。

思路:
并查集。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <vector>
#include <map>
using namespace std;
const int maxn=1005;
int a[maxn];
int n;
vector<int> h[maxn];
int vis[maxn][maxn];
int num[maxn];
map<int,int>ma;
int Find (int x)
{
    if(a[x]==x)
    {
        return x;
    }
    return a[x]=Find(a[x]);
}
void unit(int x,int y)
{
    int para=Find(x);
    int parb=Find(y);
    if(para!=parb)
    {
        a[para]=parb;
    }
}
int compare (int a,int b)
{
    return a>b;
}
int main()
{
    scanf("%d",&n);
    memset (num,0,sizeof(num));
    memset (vis,0,sizeof(vis));
    for (int i=0;i<=n;i++)
    {
        a[i]=i;
    }
    for (int i=1;i<=n;i++)
    {
        int x;
        scanf("%d:",&x);
        for (int j=0;j<x;j++)
        {
            int y;
            scanf("%d",&y);
            vis[i][y]=1;
            h[i].push_back(y);
        }
    }
    for (int i=1;i<=n-1;i++)
    {
        for (int k=0;k<h[i].size();k++)
        {
            for (int j=i+1;j<=n;j++)
            {
                if(vis[j][h[i][k]])
                    unit(j,i);
            }
        }
    }
    for (int i=1;i<=n;i++)
    {
        a[i]=Find(i);
        num[a[i]]++;
    }
    int cnt=0;
    for (int i=1;i<=1000;i++)
    {
        if(num[i])
        {
            cnt++;
        }
    }
    printf("%d\n",cnt);
    sort(num,num+1002,compare);
    for (int i=0;i<cnt;i++)
    {
        printf("%d%c",num[i],i==cnt-1?'\n':' ');
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值