A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.
Now given any two positive integers N (<105) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.
Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.
Output Specification:
For each test case, print in one line Yes
if N is a reversible prime with radix D, or No
if not.
Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No
代码如下:
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <math.h>
#include <vector>
using namespace std;
int n,d;
vector<int>ans;
bool is_prime(int x)
{
if(x==0||x==1)
return false;
for (int i=2;i<=sqrt(x);i++)
{
if(x%i==0)
{
return false;
}
}
return true;
}
int main()
{
while(scanf("%d",&n))
{
ans.clear();
if(n<0)
{
break;
}
scanf("%d",&d);
if(is_prime(n)==false)
{
printf("No\n");
continue;
}
while (n)
{
ans.push_back(n%d);
n/=d;
}
int sum=0;
for (int i=ans.size()-1,j=1;i>=0;i--,j*=d)
{
sum+=ans[i]*j;
}
if(is_prime(sum))
{
printf("Yes\n");
}
else
{
printf("No\n");
}
}
return 0;
}