UVa 725 - Division

题意:

      输入n个元素组成的序列S,找出一个乘积最大的连续子序列。如果这个最大的乘积不是正数,输出0(表示无解)。1<=n<=18,-10<=Si<=10。每一个案例之间用空白行分隔,案例输出要求输出"Case #M: The maximum product is P.",其中M为案例号,P为乘积值。

案例:

        Sample Input

        3

        2 4 -3

 

        5

        2 5 -1 2 -1

        Sample Output

        Case #1: The maximum product is 8.

 

        Case #2: The maximum product is 20.

思路:

枚举起点和终点。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
typedef long long ll;
const int maxn=20;
int a[maxn];
ll ans;
int n;
int main()
{
    int ci=0;
    while (scanf("%d",&n)!=EOF)
    {
        ci++;
        ans=0;
        for (int i=0;i<n;i++) scanf("%d",&a[i]);
        for (int i=0;i<n;i++)
        {
            ll t=1;
            for (int j=i;j<n;j++)
            {
                t*=a[j];
                ans=max(t,ans);
            }
        }
        printf("Case #%d: The maximum product is %lld.\n\n",ci,ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值