Hdu 1401 Solitaire 双向bfs

19 篇文章 0 订阅

题目:

Solitaire is a game played on a chessboard 8x8. The rows and columns of the chessboard are numbered from 1 to 8, from the top to the bottom and from left to right respectively.

There are four identical pieces on the board. In one move it is allowed to:

> move a piece to an empty neighboring field (up, down, left or right),

> jump over one neighboring piece to an empty field (up, down, left or right).



There are 4 moves allowed for each piece in the configuration shown above. As an example let's consider a piece placed in the row 4, column 4. It can be moved one row up, two rows down, one column left or two columns right.

Write a program that:

> reads two chessboard configurations from the standard input,

> verifies whether the second one is reachable from the first one in at most 8 moves,

> writes the result to the standard output.

Input

Each of two input lines contains 8 integers a1, a2, ..., a8 separated by single spaces and describes one configuration of pieces on the chessboard. Integers a2j-1 and a2j (1 <= j <= 4) describe the position of one piece - the row number and the column number respectively. Process to the end of file.

Output

The output should contain one word for each test case - YES if a configuration described in the second input line is reachable from the configuration described in the first input line in at most 8 moves, or one word NO otherwise.

Sample Input

4 4 4 5 5 4 6 5
2 4 3 3 3 6 4 6

Sample Output

YES

思路:

第一次做的是用的单向bfs,然后简单的剪了一下枝,然后tle。

然后网上的都是用的双向bfs,于是就学了一手双向bfs,建了两个队列和两个hash表,然后从起点和终点开始搜索,双向bfs一次是搜索队列的一层,而不仅仅是一个节点。

当两个hash表中都有那个元素的时候就说明找到了。

hash表的建立是运用了移位运算,因为每一位是0-7,所以只占三位,因此表示每十进制一位数的时候只需要移动三位就可以了。

代码如下:
 

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <map>
#include <queue>
using namespace std;
typedef long long ll;
struct pos
{
    int x,y;
};
pos a[4],b[4];
int loc[4][2]={{1,0},{-1,0},{0,-1},{0,1}};
map<ll,int>vis[2];
struct node
{
    int step;
    pos a[4];
};
int compare(pos a,pos b)
{
    return a.x!=b.x? a.x<b.x:a.y<b.y;
}
ll change (pos a[])
{
    sort(a,a+4,compare);
    ll ans=0;
    for (int i=0;i<4;i++)
    {
        ans|=(a[i].x<<(6*i));
        ans|=(a[i].y<<(6*i+3));
    }
    return ans;
}
int judge (pos a)
{
    if(a.x>=0&&a.x<8&&a.y>=0&&a.y<8) return 1;
    return 0;
}
int isSame (pos a[],int x)
{
    for (int i=0;i<4;i++)
    {
        if(i!=x&&a[i].x==a[x].x&&a[i].y==a[x].y) return 1;
    }
    return 0;
}
queue<node>q[2];
int bfs (int x)
{
    node now,next;
    int Size=q[x].size();
    while(Size--)
    {
        now=q[x].front(); q[x].pop();
        ll t=change(now.a);
        for (int i=0;i<4;i++)
        {
            for (int j=0;j<4;j++)
            {
                next=now;
                next.step++;
                next.a[i].x+=loc[j][0];
                next.a[i].y+=loc[j][1];
                if(judge(next.a[i]))
                {
                    if(isSame(next.a,i))
                    {
                        next.a[i].x+=loc[j][0];
                        next.a[i].y+=loc[j][1];
                        if(judge(next.a[i]))
                        {
                            if(!isSame(next.a,i))
                            {
                                ll t=change(next.a);
                                if(vis[x^1][t]==1)
                                {
                                    return 1;
                                }
                                else
                                {
                                    vis[x][t]=1;
                                    q[x].push(next);
                                }
                            }
                        }
                    }
                    else
                    {
                        ll t=change(next.a);
                        if(vis[x^1][t]==1)
                        {
                            return 1;
                        }
                        else
                        {
                            vis[x][t]=1;
                            q[x].push(next);
                        }
                    }
                }
            }
        }
    }
    return 0;
}
int tbfs ()
{
    node now1,now2;
    for (int i=0;i<4;i++)
    {
        now1.a[i]=a[i];
        now2.a[i]=b[i];
    }
    q[0].push(now1);
    ll t1=change(now1.a);
    vis[0][t1]=1;
    q[1].push(now2);
    ll t2=change(now2.a);
    vis[1][t2]=1;
    if(t1==t2) return 1;
    int step=0;
    while(!q[0].empty()||!q[1].empty())
    {
        if(step>=4) return 0;
        step++;
        if(bfs(0)) return 1;
        if(bfs(1)) return 1;
    }
    return 0;
}
int main()
{
    while(scanf("%d%d",&a[0].x,&a[0].y)!=EOF)
    {
        vis[0].clear(); vis[1].clear();
        while(!q[0].empty()) q[0].pop();
        while(!q[1].empty()) q[1].pop();
        scanf("%d%d%d%d%d%d",&a[1].x,&a[1].y,&a[2].x,&a[2].y,&a[3].x,&a[3].y);
        for (int i=0;i<4;i++) a[i].x--,a[i].y--;
        for (int i=0;i<4;i++)
        {
            scanf("%d%d",&b[i].x,&b[i].y);
            b[i].x--,b[i].y--;
        }
        if(tbfs()) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值