ZOJ - 3715 Kindergarten Election 枚举+贪心

题目:

At the beginning of the semester in kindergarten, the n little kids (indexed from 1 to n, for convenience) in class need to elect their new leader.

The ith kid will vote for his best friend fi (where 1 ≤ fi ≤ n, and it's too shame to vote for yourself, so fi ≠ i). And the kid who gets the most votes will be the leader. If more than one kids who get the largest number of votes, there will be multiple leaders in the new semester.

Little Sheldon (the kid with index 1) is extremely vain, and he would like to be the ONLY leader. (That means the number of votes he gets should strictly larger than any other.) Soon Sheldon found that if he give ci candies to the ith kid, the ith kid would regard Sheldon as the new best friend, and of course vote for Sheldon.

Every kid including Sheldon loves candies. As an evil programmer, please help the evil Sheldon become the ONLY leader with minimum cost of candies. By the way, Sheldon should vote for any one he wants EXCEPT himself.

Input

There are multiple test cases. The first line of input contains an integer T (T ≤ 100) indicating the number of test cases. Then T test cases follow.

The first line of each case contains one integer: n (3 ≤ n ≤ 100) -- the number of kids in class.

The second line contains n-1 integers: fi (1 ≤ fi ≤ n, fi ≠ i, and 2 ≤ i ≤ n) -- represents that the best friend of ith kid is indexed with fi.

The third line contains n-1 integers: ci (1 ≤ ci ≤ 1000, and 2 ≤ i ≤ n) -- represents that if Sheldon gave ci candies to the ith kid, the ith kid would vote Sheldon, instead of their old best friend fi, as the new semester leader.

Output

For each test case, print the minimal cost of candies to help Sheldon become the ONLY leader.

Sample Input

2
4
1 1 2
1 10 100
3
3 2
1 10

Sample Output

0
11

Hint

In the first case,

  • If Sheldon vote for 2nd kid, the 2nd kid and Sheldon will both have 2 votes. In this case, Sheldon have to pay 100 candies to the 4th kid, and get 3 votes to win;
  • If Sheldon vote for 3rd or 4th kid, Sheldon will win with 2 votes without sacrifice any candy.

思路:

枚举1号的初始状态i,然后去除大于等于i票的人选中的一部分票,使所有的人的票数都小于i,将这个票都加到1号,如果总票数大于n的话,则去除这种情况,如果小于,则从未被贿赂的人且不投1号的人中选,另1号票数满足于等于i。

挑选人的时候统一贿赂花费小的优先级高。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <vector>
using namespace std;
const int maxn=105;
const int INF=0x3f3f3f3f;
int t;
int n;
struct child
{
    int cho,need;
};
child a[maxn];
int num[maxn];
int compare (child a,child b)
{
    return a.need<b.need;
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        memset (num,0,sizeof(num));
        scanf("%d",&n);
        for (int i=1;i<=n-1;i++)
        {
            scanf("%d",&a[i].cho);
            num[a[i].cho]++;
        }
        for (int i=1;i<=n-1;i++)
        {
            scanf("%d",&a[i].need);
        }
        int ans=INF;
        for (int i=max(1,num[1]);i<=n-1;i++)
        {
            int vis[maxn];
            int sum=0,huo=0;
            int cost=0,ok=0;
            for (int j=2;j<=n;j++) if(num[j]>i-1) sum+=num[j]-(i-1);
            if(sum+num[1]>n-1) continue;
            huo=sum+num[1];
            ok=1;
            memset (vis,0,sizeof(vis));
            for (int j=2;j<=n;j++)
            {
                if(num[j]<=i-1) continue;
                int len=0;
                child b[maxn];
                for (int k=1;k<=n-1;k++)
                {
                    if(a[k].cho==j)
                    {
                        b[len].need=a[k].need;
                        b[len++].cho=k;
                    }
                }
                sort(b,b+len,compare);
                int ci=num[j]-(i-1);
                for (int k=0;k<ci;k++)
                {
                    cost+=b[k].need;
                    vis[b[k].cho]=1;
                }

            }
            int len=0;
            int c[maxn];
            for (int j=1;j<=n-1;j++)
            {
                if(!vis[j]&&a[j].cho!=1) c[len++]=a[j].need;
            }
            sort(c,c+len);
            for (int j=0;j<i-huo;j++) cost+=c[j];
            if(ok) ans=min(cost,ans);
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值