HDU 1004 Let The Balloon Rise (简单map)

H - Let the Balloon Rise

HDU - 1004

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

InputInput contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
OutputFor each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
Sample Output
red
pink

这道题就是简单的字符串水题,但是用stl做可以练习一下map,有两种基本方法

一:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<vector>
#include<set>
#include<map>
#include<queue>
#include<cmath>
using namespace std;
int main()
{
    map<string,int>balloons;
    string a;
    int maxy;
    string col;
    int n;
    while(scanf("%d",&n)!=EOF&&n)
    {
        balloons.clear();
        while(n--)
        {
            cin>>a;
            balloons[a]++;
        }
        map<string,int>::iterator it;
        maxy = -1;
        for(it = balloons.begin(); it != balloons.end(); it++)//遍历
        {
//            if((*it).second > maxy)
//            {
//                maxy = (*it).second;
//                col = (*it).first;
//            }
            if(it -> second > maxy)
                {
                    maxy = it -> second;
                    col = it -> first;
                }
        }
        cout<<col<<endl;
    }
    return 0;
}

二:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<vector>
#include<set>
#include<map>
#include<queue>
#include<cmath>
using namespace std;

int main()
{
    map<string,int>balloons;
    string a;
    string col;
    int n;
    while(scanf("%d",&n)!=EOF&&n)
    {
        balloons.clear();
        while(n--)
        {
            cin>>a;
            balloons[a]++;
        }
        map<string,int>::iterator i, j;
        j = balloons.begin();
        for(i = balloons.begin(); i != balloons.end(); i++)
        {
            if(i -> second > j -> second)
            {
                j = i;
            }
        }
        cout<<j -> first<<endl;
    }
    return 0;
}

map conut + find

使用count,返回的是被查找元素的个数。如果有,返回1;否则,返回0。注意,map中不存在相同元素,所以返回值只能是1或0。

使用find,返回的是被查找元素的位置,没有则返回map.end()



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值