POJ 2752 Seek the Name, Seek the Fame

H - Seek the Name, Seek the Fame 

                                 POJ - 2752

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father's name and the mother's name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)
Input
The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.
Output
For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.
Sample Input
ababcababababcabab
aaaaa
Sample Output
2 4 9 18
1 2 3 4 5

考察对 next 数组的掌握情况,题意是给定一个字符串s,寻找有几个字符串既是s的前缀又是s的后缀,找到并输出符合情况字符串的长度,可以分析出所有前缀都包含在最长的前缀之中并且符合条件的前缀的最后一个字符一定是s的最后一个字符

其实应该这样理解

 next数组存放的是字符串的前缀和后缀能匹配的字符个数的最大值

        如果next[i]  == 0或-1则表示 由s的前i个字符组成的字符串的所有后缀肯定和其前缀不匹配

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<vector>
#include<set>
#include<map>
#include<queue>
#include<cmath>
using namespace std;
char a[400005];
int ne[400005];
int ans[400005];//记录可能的答案,不能开的太小,防止字符串是aaaaa之类的情况
void findnext()
{
    int len = strlen(a);
    int i = 0, j = -1;
    ne[0] = -1;
    while(i < len)
    {
        if(j == -1 || a[i] == a[j])
            ne[++i] = ++j;
        else j = ne[j];
    }
}
int main()
{
    while(scanf("%s",a)!=EOF)
    {
        int len = strlen(a);
        findnext();
//        for(int i = 0; i < strlen(a); i ++)
//            cout<<ne[i]<<' ';
//        cout<<endl;
        int cnt = 0;
        int now;
        now = ne[len - 1];
        while(now != -1)//循环终止条件
        {
            if(a[now] == a[len - 1])//想要是符合条件,前缀必须最后一位必定等于s的最后一位
                ans[cnt++] = now + 1;
                now = ne[now];//更新位置,遍历所有符合条件的点
        }
        for(int i = cnt - 1; i >= 0; i --)
            printf("%d ",ans[i]);
        printf("%d\n",len);

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值