UVA 11401 Triangle Counting

Question:
You are given n rods of length 1, 2, … , n. You have to pick any 3 of them and build a triangle. How
many distinct triangles can you make? Note that, two triangles will be considered different if they have
at least 1 pair of arms with different length.
Input
The input for each case will have only a single positive integer n (3 ≤ n ≤ 1000000). The end of input
will be indicated by a case with n < 3. This case should not be processed.
Output
For each test case, print the number of distinct triangles you can make.
Sample Input
5
8
0
Sample Output
3
22

设三条边为x,y,z;最长边为x;       x-z<y<x;   先开始的时候想着z=1的时候,z=2的时候,把图画出来是两条平行线。。。。。一脸懵逼,过了一会才明白这是具体的值。z=2时,y=x-1;有1个值,以此类推0,1,2,3,x-2;  (x-1)(x-2)/2.这时候肯定有y=z的时候

在(x/2+1,x-1)的时候有重复把他的值/2;因为此时还要分奇偶,就把结果直接用(x-1)/2表示,就可以得出结论。

#include<stdio.h>
#include<iostream>
#define ll long long
#define maxn 1000000+5
using namespace std;
ll a[maxn];
/*int fun()
{
	a[1]=0;
	a[2]=0;
	a[3]=0;
	for(ll i=4;i<1000005;i++)
	{
		a[i]=a[i-1]+((i-2)*(i-1)/2-(i-1)/2)/2;	
	}	
	return 0;
}*/
int main()
{
	ll n;
	a[3]=0;
	for(ll i=4;i<1000005;i++)
	{
		a[i]=a[i-1]+((i-1)*(i-2)/2-(i-1)/2)/2;	
	}	
	while(~scanf("%lld",&n))
	{
		if(n<3) break;
	//	fun();
		//fun(n);
		printf("%lld\n",a[n]);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值