hdu 1355 The Peanuts(模拟)

The Peanuts

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 313    Accepted Submission(s): 174


 

Problem Description

Mr. Robinson and his pet monkey Dodo love peanuts very much. One day while they were having a walk on a country road, Dodo found a sign by the road, pasted with a small piece of paper, saying "Free Peanuts Here! " You can imagine how happy Mr. Robinson and Dodo were.

There was a peanut field on one side of the road. The peanuts were planted on the intersecting points of a grid as shown in Figure-1. At each point, there are either zero or more peanuts. For example, in Figure-2, only four points have more than zero peanuts, and the numbers are 15, 13, 9 and 7 respectively. One could only walk from an intersection point to one of the four adjacent points, taking one unit of time. It also takes one unit of time to do one of the following: to walk from the road to the field, to walk from the field to the road, or pick peanuts on a point.
 



According to Mr. Robinson's requirement, Dodo should go to the plant with the most peanuts first. After picking them, he should then go to the next plant with the most peanuts, and so on. Mr. Robinson was not so patient as to wait for Dodo to pick all the peanuts and he asked Dodo to return to the road in a certain period of time. For example, Dodo could pick 37 peanuts within 21 units of time in the situation given in Figure-2.

Your task is, given the distribution of the peanuts and a certain period of time, tell how many peanuts Dodo could pick. You can assume that each point contains a different amount of peanuts, except 0, which may appear more than once.

 


 

Input

The first line of input contains the test case number T (1 <= T <= 20). For each test case, the first line contains three integers, M, N and K (1 <= M, N <= 50, 0 <= K <= 20000). Each of the following M lines contain N integers. None of the integers will exceed 3000. (M * N) describes the peanut field. The j-th integer X in the i-th line means there are X peanuts on the point (i, j). K means Dodo must return to the road in K units of time.

 


 

Output

For each test case, print one line containing the amount of peanuts Dodo can pick.

Sample Input

2 6 7 21 0 0 0 0 0 0 0 0 0 0 0 13 0 0 0 0 0 0 0 0 7 0 15 0 0 0 0 0 0 0 0 9 0 0 0 0 0 0 0 0 0 0 6 7 20 0 0 0 0 0 0 0 0 0 0 0 13 0 0 0 0 0 0 0 0 7 0 15 0 0 0 0 0 0 0 0 9 0 0 0 0 0 0 0 0 0 0

Sample Output

37 28

Recommend

JGShining

把花生的质量从大到小排序,然后模拟拿就行。

#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
#define maxn 55 
using namespace std;
struct node
{
	int x;
	int y;
	int sum;
}ac[maxn*maxn];
int cmp(node a,node b)
{
	return a.sum>b.sum;
}
int fabs(int x)
{
    return x>0?x:-x;
}
int main()
{
	int n;
	cin>>n;
	while(n--)
	{
		int x1,y1,t;
		cin>>x1>>y1>>t;
		int l=0;
		for(int i=1;i<=x1;i++)
		{
			for(int j=1;j<=y1;j++)
			{
				int gra;
				cin>>gra;
				ac[l].x=i,ac[l].y=j,ac[l].sum=gra;
				l++;
			}
		}
		sort(ac,ac+l,cmp);
		int dx=0,dy=ac[0].y,pt=0,ans=0;
		for(int i=0;i<l;i++)
		{
			if(ac[i].sum==0) break;
			//d=abs(ac[i].x-dx)+abs(ac[i].y-dy);
			if(pt+fabs(ac[i].x-dx)+fabs(ac[i].y-dy)+ac[i].x+1<=t) 
			{
				pt+=fabs(ac[i].x-dx)+fabs(ac[i].y-dy)+1;
				dx=ac[i].x;
				dy=ac[i].y;
				ans+=ac[i].sum;
				//pt+=fabs(ac[i].x-dx)+fabs(ac[i].y-dy)+1;
			}
			else break;
		}
		cout<<ans<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值