poj27854 Values whose Sum is 0

11 篇文章 0 订阅

http://poj.org/problem?id=2785

4 Values whose Sum is 0

Time Limit: 15000MS Memory Limit: 228000K
Total Submissions: 28927 Accepted: 8753
Case Time Limit: 5000MS

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

Source

Southwestern Europe 2005

四个数的和为0完全可以转化为两个数的和为0,用二分法,注意一个数可能与多个数的和为0,这时候二分不能找到就return1;

#include<iostream>
#include<algorithm>
#define maxn 4002
using namespace std;
int a[maxn];
int b[maxn];
int c[maxn];
int d[maxn];
int q[maxn*maxn];
int q1[maxn*maxn];
int sum=0;
int quick(int ans,int k)
{
	int l=0,r=k-1;
	while(l<r)
	{
		int mid=(l+r)/2;
		if(q1[mid]<ans) l=mid+1;
		else  r=mid;
	}
	while(q1[l]==ans&&l<k)
	{
		sum++;
		l++;
	}
	return 0;
}
int main()
{
	int n;
	cin>>n;
	for(int i=0;i<n;i++)
	cin>>a[i]>>b[i]>>c[i]>>d[i];
	int k=0;int k1=0;
	for(int i=0;i<n;i++)
	{
		for(int j=0;j<n;j++)
		{
			q[k++]=a[i]+b[j];
			q1[k1++]=c[i]+d[j];
			//cout<<c[k]<<" ";
	
		}
	}
	sort(q,q+k);
	sort(q1,q1+k1);
	int ans;
	for(int i=0;i<k;i++)
	{
		 ans=-q[i];
		//cout<<ans<<endl;
		quick(ans,k1);
	}
	cout<<sum<<endl;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值