ACM刷题之路(一)第K个排列问题 Ignatius and the Princess II

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=1027

Problem Description

Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
Can you help Ignatius to solve this problem?

 

 

Input

The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.

 

 

Output

For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.

 

 

Sample Input

 

6 4 11 8

 

 

Sample Output

 

1 2 3 5 6 4 1 2 3 4 5 6 7 9 8 11 10


题目意思:

输入n,m;n是数字的个数,m是求从小到大第m个排列。

如n = 4,m = 2,就是1,2,3,4这四个数第二个排列,即1,2,4,3。

如n = 3 , m = 3,就是1,2,3这六个数的第三个排列,就是2,1,3。


题解:

1. 使用next_permutation()函数:

使用时第一个参数代表首地址,第二个参数代表尾地址,比如next_permutation(a,a+n).求第M小的数列,只要让原来从小到大的数列执行m-1次next_permutation()函数即可,这题使用这个方法完全可以AC,只要93ms,但是数据范围如果很大就会超时。就像蔡老师说的“程序员是很懒的”,在使用函数能解决的情况下,就使用这个函数A题。

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;

#define N 1002
int num[N];
int main()
{
	int n, m;
	while (~scanf("%d%d", &n, &m))
	{
		memset(num, 0, sizeof(num));
		for (int i = 0; i < n; i++){
			num[i] = i + 1; // 初始化为1 到 n
		}
		for (int i = 1; i < m; i++){
			next_permutation(num, num + n);//反复求下一个排列
		}
		for (int i = 0; i < n - 1; i++) {
			printf("%d ", num[i]);//输出
		}
		printf("%d\n", num[n - 1]);
	}
	return 0;
}

2.使用阶乘的思想

比如n = 5, m = 6(提示:6 = 3 ! ),只会对(3 + 1 )位数字发生变化,前面第一位数字不会改变。

比如n = 100   m = 24(提示:24 = 4!) ,只会对后(4+1)位数字发生变化,前面95个数字依旧不会改变。

这是m刚刚好为一个数的阶乘的情况,那么重点来了,如果不等于,我们可以拆开来 ,1的阶乘为1。

 

 

代码用阶乘讨论

#include<stdio.h>  
#include<string.h>  

int a[10] = { 1,1,2,6,24,120,720,5040 };//阶乘数组
int b[10];

int main()
{
    int n, m, i, k, t;
    while (~scanf("%d%d", &n, &m)){
        for (i = 1; i <= n - 8; i++) {
            printf("%d ", i);
        }
        for (k = 0; i <= n; i++) {
            b[k++] = i;
        }
        if (n > 8) n = 8;
        for (i = n; i > 1; i--){
            t = (m - 1) / a[i - 1];
            for (k = 0; k < 8 && k < n; k++){
                if (b[k] && t == 0){
                    printf("%d ", b[k]);
                    b[k] = 0;
                    break;
                }
                else if (b[k]) t--;
            }
            m = (m - 1) % a[i - 1] + 1;
        }
        for (k = 0; k < 8 && k < n; k++) {
            if (b[k]) printf("%d\n", b[k]);
        }
    }
    return 0;
}

初次写博客,不足之处,敬请谅解

  • 12
    点赞
  • 12
    收藏
    觉得还不错? 一键收藏
  • 5
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 5
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值