Don't Get Rooked

来源:https://blog.csdn.net/jhc23/article/details/9977669

题目描述

In chess, the rook is a piece that can move any number of squares vertically or horizontally. In this problem we will consider small chess boards (at most 4x4) that can also contain walls through which rooks cannot move. The goal is to place as many rooks on a board as possible so that no two can capture each other. A configuration of rooks is legal provided that no two rooks are on the same horizontal row or vertical column unless there is at least one wall separating them. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of rooks in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 

Your task is to write a program that, given a description of a board, calculates the maximum number of rooks that can be placed on the board in a legal configuration. 

输入

The input contains one or more board descriptions, followed by a line containing the number 0 that signals the end of the file. Each board description begins with a line containing a positive integer n that is the size of the board; n will be at most 4. The next n lines each describe one row of the board, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input.

输出

For each test case, output one line containing the maximum number of rooks that can be placed on the board in a legal configuration.

样例输入

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

样例输出

5
1
5
2
4

解析:

题意:在一个图上放石头,要求不可以同行同列,但是可以隔墙放

算法实现:

#include<stdio.h>
#include<string.h>
#include <iostream>
using namespace std;
int n,ans;
char map[6][6],vis[6][6];//vis用来记录地图上是否已经放了石子 
int isok(int x,int y)//这里需要判断是否可放
{   
    int i;
    if(vis[x][y]==1||map[x][y]=='X')
    return 0;
    for( i=x-1;i>=0&&map[i][y]!='X';i--)//竖直方向
    {
        if(vis[i][y]==1)
        return  0;
    }
    for( i=y-1;i>=0&&map[x][i]!='X';i--)//水平方向
    {
        if(vis[x][i]==1)
        return  0;
    }
    return 1;
}
void dfs(int cur,int s)//s用来记录放的石子数,cur用来记录是从第cur个位置开始查找的 
{
    if(cur==n*n)return;
    for(int k=cur;k<n*n;k++)//每次都是从不同的起点开始
    {   
        int i=k/n;
        int j=k%n;//i,k分别用来记录起点位置坐标 
        if(isok(i,j))//判断是否可以在这个坐标放石子 
        {
            vis[i][j]=1;
            if(s+1>ans)
            ans=s+1;
            dfs(k+1,s+1);//查找下一个 
            vis[i][j]=0;//回溯
        }
    }
}
int main()
{
    int i,j;
    while(cin>>n,n!=0)
    {
        for(i=0;i<n;i++)
        cin>>map[i];
        ans=0;
        memset(vis,0,sizeof(vis));
        dfs(0,0);
        cout<<ans<<endl;
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值