XOR Clique

https://pintia.cn/problem-sets/1036903825309761536/problems/1041156503909756928

 

K XOR Clique

BaoBao has a sequence a​1​​,a​2​​,...,a​n​​. He would like to find a subset S of {1,2,...,n} such that ∀i,j∈S, a​i​​⊕a​j​​<min(a​i​​,a​j​​) and ∣S∣ is maximum, where ⊕ means bitwise exclusive or.

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains an integer n (1≤n≤10​5​​), indicating the length of the sequence.

The second line contains n integers: a​1​​,a​2​​,...,a​n​​ (1≤a​i​​≤10​9​​), indicating the sequence.

It is guaranteed that the sum of n in all cases does not exceed 10​5​​.

Output

For each test case, output an integer denoting the maximum size of S.

Sample Input

3
3
1 2 3
3
1 1 1
5
1 2323 534 534 5

Sample Output

2
3
2

作者: 浙江大学竞赛命题组

单位: ACMICPC

时间限制: 500 ms

内存限制: 64 MB

代码长度限制: 32 KB

 

 

#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
	int i,j;
	for(i=0;i<=16;i++)
	{
		for(j=0;j<=100;j++)
		{
			if((i^j)<min(i,j))
			printf("%d %d\n",i,j);
		
		}
	}
	return 0;
}

可以看出规律,符合条件的在2^n与2^(n+1)之间,所以只要求在哪个阶段中的数最多即可。

#include<stdio.h>
#include<stdlib.h>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 120
int a[N];
int main()
{
	int n,i,j,t,maxn,x;
	scanf("%d",&t);
	while(t--)
	{    
		maxn=0;
		memset(a,0,sizeof(a));
		scanf("%d",&n);
		for(i=1;i<=n;i++)
		{
			scanf("%d",&x);
			for(j=0;;j++)
			{
				if(x>=pow(2,j)&&x<pow(2,j+1))
				{
					a[j]++;	
					maxn=max(a[j],maxn);
					break;
				}
			}
		}
		printf("%d\n",maxn);
	}
	return 0;
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 4
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

张宜强

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值