POJ1562:Oil Deposits(dfs)

http://poj.org/problem?id=1562

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

'@'代表油,相邻的油组成一个油块,问有多少油块。

这里的相邻包括周围的8个位置。

#include<stdio.h>
#include<string.h>
#define N 120
char str[N][N];
int book[N][N];
int n,m;
void dfs(int x,int y,int t)
{
	int tx, ty, i;
	int next[8][2]={-1,-1, -1,0, -1,1, 0,-1, 0,1, 1,-1, 1,0, 1,1};
	book[x][y]=t;
	for(i=0; i<8; i++)
	{
		tx=x+next[i][0];
		ty=y+next[i][1];
		if(tx>=m || tx<0 || ty>=n || ty<0)
			continue;
		if(book[tx][ty]==0 && str[tx][ty]=='@')
			dfs(tx,ty,t);
	}
	return ;
}
int main()
{
	int i,t,j;
	while(scanf("%d%d",&m,&n),m!=0)
	{
		for(i=0;i<m;i++)
			scanf("%s",str[i]);
		memset(book,0,sizeof(book));
		t=0;
		for(i=0;i<m;i++)
			for(j=0;j<n;j++)
			{
				if(str[i][j]=='@'&&book[i][j]==0)
				{
					t++;
					dfs(i,j,t);
				}			
			}
		printf("%d\n",t);	
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

张宜强

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值