河南省第六届大学生程序设计竞赛 : Card Trick(模拟)

12 篇文章 0 订阅
12 篇文章 0 订阅

http://acm.zzuli.edu.cn/problem.php?id=1486

题目描述

The magician shuffles a small pack of cards, holds it face down and performs the following procedure:

1. The top card is moved to the bottom of the pack. The new top card is dealt face up onto the table. It is the Ace of Spades. 

2. Two cards are moved one at a time from the top to the bottom. The next card is dealt face up onto the table. It is the Two of Spades. 

3. Three cards are moved one at a time… 

4. This goes on until the nth and last card turns out to be the n of Spades.

This impressive trick works if the magician knows how to arrange the cards beforehand (and knows how to give a false shuffle). Your program has to determine the initial order of 



the cards for a given number of cards, 1 ≤ n ≤ 13.

输入

On the first line of the input is a single positive integer k, telling the number of test cases to follow. 1 ≤ k ≤ 10  Each case consists of one line containing the integer n.  1 ≤ n ≤ 13

输出

For each test case, output a line with the correct permutation of the values 1 to n, space separated. The first number showing the top card of the pack, etc…

样例输入 Copy

2
4
5

样例输出 Copy

2 1 4 3
3 1 4 5 2

题意分析:

一副扑克牌,要拿一张放在末尾,第一张牌是1,把1拿走,

再拿出两张牌放在末尾,第一张牌是2,把2拿走,

再拿出三张牌放在末尾,第一张牌是3,把3拿走,

..................

以此类推,问最开始牌的顺序是什么。

解题思路:

反着来想,第一张牌是n,从末尾拿出n张牌放在上面,

现在第一张牌是n-1,从末尾拿出n-1张牌放在上面,

................

以此类推。

#include <stdio.h>
#include <string.h>
#define N 1020
int a[N];
int main()
{
	int T,n,i,m,j;
	scanf("%d", &T);
	while(T--){
		memset(a , 0 , sizeof(a));
		scanf("%d", &n);
		m = n;
		j = 0;
		while(m >= 1){
			a[j++] = m;
			for(i = 0; i < m; i++){
				a[j] = a[j- (n-m) ];
				j++;
			}	
			m--;
		}
		for(i = j-1; i>=j-n; i--)
			printf("%d ", a[i]);
		printf("\n"); 
	}
	return 0;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

张宜强

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值