hdu2988:Dark roads(最小生成树)

http://acm.hdu.edu.cn/showproblem.php?pid=2988

 

Problem Description

Economic times these days are tough, even in Byteland. To reduce the operating costs, the government of Byteland has decided to optimize the road lighting. Till now every road was illuminated all night long, which costs 1 Bytelandian Dollar per meter and day. To save money, they decided to no longer illuminate every road, but to switch off the road lighting of some streets. To make sure that the inhabitants of Byteland still feel safe, they want to optimize the lighting in such a way, that after darkening some streets at night, there will still be at least one illuminated path from every junction in Byteland to every other junction.

What is the maximum daily amount of money the government of Byteland can save, without making their inhabitants feel unsafe?
 

 

 

Input

The input file contains several test cases. Each test case starts with two numbers m and n, the number of junctions in Byteland and the number of roads in Byteland, respectively. Input is terminated by m=n=0. Otherwise, 1 ≤ m ≤ 200000 and m-1 ≤ n ≤ 200000. Then follow n integer triples x, y, z specifying that there will be a bidirectional road between x and y with length z meters (0 ≤ x, y < m and x ≠ y). The graph specified by each test case is connected. The total length of all roads in each test case is less than 231.

 

 

Output

For each test case print one line containing the maximum daily amount the government can save.

 

 

Sample Input

7 11
0 1 7
0 3 5
1 2 8
1 3 9
1 4 7
2 4 5
3 4 15
3 5 6
4 5 8
4 6 9
5 6 11
0 0

Sample Output

51

题意分析:

现在有多条道路上路灯耗电的情况,政府想要节省电费,但是要求每个路口都要有一条与它连接的街道亮灯,问最多可以省下的电费。

解题思路:

把路灯的耗电当作边的权值,求最小生成树,用总的耗电减去最小耗电。

#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;
#define N 200200
struct data{
	int u;
	int v;
	int w;
}e[N];
int f[N];
int cmp(data a, data b)
{
	return a.w<b.w;
}
int getf(int v)
{
	if(f[v]==v)
		return v;
	else
	{
		f[v]=getf(f[v]);
		return f[v];
	}
}
int merge(int v, int u)
{
	int t1, t2;
	t1=getf(v);
	t2=getf(u);
	if(t1!=t2)
	{
		f[t2]=t1;
		return 1;
	}
	return 0;
}
int main()
{
	int i, n, m, count, sum, ans;
	while(scanf("%d%d", &n, &m)!=EOF)
	{
		if(m==0&&n==0)
			break;
		sum=0;
		for(i=1; i<=m; i++)
		{
			scanf("%d%d%d", &e[i].u, &e[i].v, &e[i].w);	
			sum+=e[i].w;
		}
		sort(e+1, e+m+1, cmp);
		for(i=0; i<n; i++)
			f[i]=i;
			
		ans=0;
		count=0;
		for(i=1; i<=m; i++)
		{
			if(merge(e[i].u, e[i].v))
			{
				count++;
				ans+=e[i].w;
			}
			if(count==n-1)
				break;
		}
		printf("%d\n", sum-ans);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

张宜强

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值