hdu1068:Girls and Boys(最大独立集)

72 篇文章 0 订阅
30 篇文章 0 订阅

http://acm.hdu.edu.cn/showproblem.php?pid=1068

Problem Description

the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.

 

 

Sample Input

7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

Sample Output

5
2

题意分析:

有n个人,给出这n个人认识的其他人,要求找出一个集合,使集合中的人两两都不认识,并且人数最多。

解题思路:

如果集合中有人相识就把他们去掉,也就是求出最大匹配,用总人数减去匹配人数的一半。

最大独立集人数=总人数-最大匹配人数/2。

#include <stdio.h>
#include <string.h>
#define N 1005
int e[N][N], book[N], a[N];
int n;
int dfs(int u)
{
	int i;
	for(i=1; i<=n; i++)
	{
		if(book[i]==0 && e[u][i]==1)
		{
			book[i]=1;
			if(a[i]==0 || dfs(a[i]))
			{
				a[i]=u;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int i, j, t, u, ans;
	while(scanf("%d", &n)!=EOF)
	{
		ans=0;
		memset(e, 0, sizeof(e));
		memset(a, 0, sizeof(a));
		for(i=0; i<n; i++)
		{
			scanf("%d: ", &j);
			scanf("(%d)", &t);
			while(t--)
			{
				scanf("%d", &u);
				e[j+1][u+1]=1;	
			}		
		}	
		for(i=1; i<=n; i++)
		{
			memset(book, 0, sizeof(book));
			if(dfs(i))
				ans++;	
		}
		printf("%d\n", n-ans/2);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

张宜强

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值