http://poj.org/problem?id=3259
Description
While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.
As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .
To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.
Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
Sample Input
2 3 3 1 1 2 2 1 3 4 2 3 1 3 1 3 3 2 1 1 2 3 2 3 4 3 1 8
Sample Output
NO YES
题意分析:
John有一个农场,农场上有双向道路和虫洞,利用虫洞可以回到以前一段时间,现在John想知道有没有一种方案可以回到他走这条路之前的时间。
解题思路:
把双向道路的通过时间当成权值,虫洞的返回的时间作为负权值,判断图中是否存在负环。
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <vector>
#define N 550
using namespace std;
struct edge{
int u;
int v;
int w;
}a[N*20];
int dis[N];
int main()
{
int T, n, m, w, i, j, k, inf=0x9f9f9f;
scanf("%d", &T);
while(T--)
{
scanf("%d%d%d", &n, &m, &w);
for(i=1; i<=m+w; i++)
{
scanf("%d%d%d", &a[i].u, &a[i].v, &a[i].w);
if(i>m)
a[i].w=-a[i].w;
else
{
a[i+w+m].u=a[i].v;
a[i+w+m].v=a[i].u;
a[i+w+m].w=a[i].w;
}
}
memset(dis, inf, sizeof(dis));
dis[1]=0;
for(k=1; k<n; k++)
{
int temp=0;
for(i=1; i<=2*m+w; i++)
if(dis[a[i].u]>dis[a[i].v]+a[i].w)
{
temp=1;
dis[a[i].u]=dis[a[i].v]+a[i].w;
}
if(temp==0)
break;
}
int temp=0;
for(i=1; i<=2*m+w; i++)
if(dis[a[i].u]>dis[a[i].v]+a[i].w)
{
temp=1;
break;
}
if(temp==0)
printf("NO\n");
else printf("YES\n");
}
return 0;
}