hdu 2602:Bone Collector(01背包)

http://acm.hdu.edu.cn/showproblem.php?pid=2602

 

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

 

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

 

 

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

 

Sample Output

14

题意分析:

有一个骨头收集者,有一个体积为V的口袋,每个骨头有自己的价值和体积,求最多能装入口袋骨头的价值是多少。

解题思路:

01背包,注意第一行是价值,第二行是体积。

#include <stdio.h>
#include <string.h>
#include <algorithm>
#define N 1020
using namespace std;
struct date{
	long long v;
	long long w;
}a[N];
long long dp[N];
int main()
{
	int t, n, m, i, j;
	scanf("%d", &t);
	while(t--)
	{
		memset(dp, 0, sizeof(dp));
		scanf("%d%d", &n, &m);	
		for(i=1; i<=n; i++)
			scanf("%lld", &a[i].v);
		for(i=1; i<=n; i++)
			scanf("%lld", &a[i].w);
		for(i=1; i<=n; i++)
			for(j=m; j>=a[i].w; j--)
				dp[j]=max(dp[j], dp[j-a[i].w]+a[i].v);
		printf("%lld\n", dp[m]);
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

张宜强

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值