POJ2533——动规解决最长上升子序列

很典型的动态规划入门例题。

原序列a,dp[i]表示以a[i]结尾的最长上升子序列的长度。

初始状态:dp[i] = 1,表示将a[i]插进结果序列的末端。

两个循环:外层为 i:1 ~ N  ;  内层为 j:1 ~ i。

对应每个i和j,如果有a[i]>a[j],那么dp[i]有两种选择:

1. 将dp[j]对应的序列插到a[i]前面;(此时dp[j]已是一个求好的最长上升子序列)

2. 选择不插进去。

于是有这样的状态转移方程:

dp[i] = max( dp[i] , dp[j] + 1 ),即max{ 不插进去,插进去(dp[j]+1)}

最后,要求出所有dp[i]的最大值,这个最大值才是所求最长上升子序列的长度。

题目:

A numeric sequence of  ai is ordered if  a1 <  a2 < ... <  aN. Let the subsequence of the given numeric sequence (  a1a2, ...,  aN) be any sequence (  ai1ai2, ...,  aiK), where 1 <=  i1 <  i2 < ... <  iK <=  N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8). 

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000 
Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence. 
Sample Input
7
1 7 3 5 9 4 8
Sample Output
4


代码:

//
//  main.cpp
//  POJ2533
//
//  Created by jinyu on 2018/7/15.
//  Copyright © 2018年 jinyu. All rights reserved.
//

#include <iostream>
#include <algorithm>
using namespace std;
int a[1000+77];
int dp[1000+77];
int main(){
    
    int N,res;
    while(cin>>N){
        memset(dp, 0, sizeof(dp));
        res = 0;
        for(int i = 0;i<N;i++){
            cin>>a[i];
        }
        for(int i = 0;i<N;i++){
            dp[i] = 1;
            for(int j = 0;j<i;j++){
                if(a[i] > a[j]){
                    dp[i] = max(dp[i] , dp[j] + 1);
                }
            }
        }
        for(int i = 0;i<N;i++){
            if(dp[i] > res){
                res = dp[i];
            }
        }
        cout<<res<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值