POJ 1004 Financial Management Writeup

萌新试水,求平均数的水题,大佬请忽略。。

                                               Financial Management
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 109258 Accepted: 47427

Description

Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

Input

The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.

Output

The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.

Sample Input

100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75

Sample Output

$1581.42

Source


翻译:

                                                       经济管理

  拉里今年毕业后终于找到了一份工作。他赚了很多钱但不知道为什么看起来永远不够用。拉里决定,他需要掌握开销组合来解决他的经济问题。第一步就是要找出他的钱到底出了什么问题。为了搞清楚自己到底有多少钱,拉里去银行拿到了他的账单。请写一个能从拉里过去几年的期终余额来计算他的平均账户余额的程序来帮助他。

输入

  输入有十二行,每一行会包含他某一个月的期终账户余额,每一个数字都是正的并精确到美分,并且不会包含美元符号。

输出

  输出的十二个月的平均期终余额应是一个单独的数字,并且每行开头应有一个美元符号。输出不会包含其他的字符和空格。


解题思路

  就是求平均数啊有什么解题思路。。

注意点

  感觉除了输出控制两位小数以外没有什么要注意的了吧。

对比

  好像就我个智障用了数组。。

/*
	Memory:200k
	Time:0MS
*/
#include <cstdio>
using namespace std;
int main()
{
	const int MAXSIZE=12+5;
	float cl_balance[MAXSIZE],tot=0;
	for(int n=0;n<12;n++)
	{
		scanf("%f",&cl_balance[n]);
		tot+=cl_balance[n];
	}
	printf("$%.2f",tot/12);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值