1270: Swap Digits

1270: Swap Digits

      Time Limit: 1 Sec     Memory Limit: 128 Mb     Submitted: 652     Solved: 236    

Description

Now we have a number, you can swap any two adjacent digits of it, but you can not swap more than K times. Then, what is the largest probable number that we can get after your swapping?

Input

There is an integer T (1 <= T <= 200) in the first line, means there are T test cases in total.

For each test case, there is an integer K (0 <= K < 106) in the first line, which has the same meaning as above. And the number is in the next line. It has at most 1000 digits, and will not start with 0.

There are at most 10 test cases that satisfy the number of digits is larger than 100.

Output

For each test case, you should print the largest probable number that we can get after your swapping.

Sample Input

3
2
1234
4
1234
1
4321

Sample Output

3124
4213
4321

题目大意是给你一个数,每次可以交换相邻的两个数,问最多进行K次交换之后能得到的最大的数是多少。不交换或者不交换那么多次也是可以的。

解题思路是用字符数组接受这个数,从0号到K号找最大的元素(因为每次都只能交换相邻的两个数,所以最多可以将第K的位置的数交换到第一个),将它放到0号位置,从0到最大的那个数依次后移(就是模拟将0到K号位置内最大元素交换到0号位置的过程),假设在L位置,则将L号位置交换到0号需要L步,K自减L。然后从1号位置开始,重复上述步骤。最后得到的就是最大数了。下面看代码,不懂再问吧

#include<iostream>
#include<string>
#include<cstring>
using namespace std;
int main()
{
	int t;
	string str;
	scanf("%d",&t);
	while (t--)
	{
		int k;
		scanf ("%d",&k);
		cin >> str;
		for (int i = 0; i < str.size(); i++)
		{
			char ma = '0';
			int w = 0;
			for (int j = i; j < str.size() && j <= i + k; j++)
			{
				if (str[j] > ma)
				{
					ma = str[j];
					w = j;
				}
			}
			if (ma > str[i])
			{
				for (int j = w; j > i; j--)
				{
					str[j] = str[j - 1];
				}
				str[i] = ma;
				k -= w - i;
			}
		}
		cout << str << endl;
	}
	return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值