B - Relatives

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output

For each test case there should be single line of output answering the question posed above.

Sample Input

7
12
0

Sample Output

6
4
#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long ll;
const int maxn = 1e5+5;
int v[maxn];
int main()
{
	int t,n;
	while(scanf("%d",&t) && t)
	{
		int s = 1; n = t;
		for (int i = 2;i * i <= t;)
		{
			int k=0;
			while(t%i == 0)//找公因子 
			{
				if(!k)//巧妙,比如12,第二次除以2时,不用执行 
				{
					k = 1;
					v[s++] = i;
				}
				t /= i;
			}
			if ( i == 2 ) i++;
			else i += 2;
			//i++;
		}
		ll sum = 0;
		if (t != 1) v[s++] = t; s -= 1;//ss是公因子个数 
		for (int i = 1;i < (1 << s);i++)
		{
			ll cnt = 0,tmp = 1;
			for (int j = 1; j <= s ;j++)//?????j=1
			{
				if ( i >> (j-1) & 1 )  
				{
					cnt++;
					tmp = tmp * v[j];//与n有公因子的数 
				} 
			}
			if(cnt & 1) sum += n  / tmp;
			else sum -= n / tmp;
		}
		printf("%d\n",n - sum);
	}
	return 0;
}
/* 题目要求1..n-1中与n互质的数的个数 */
//ll gcd(ll a,ll b){
//	if(b == 0){
//		return a;
//	} else {
//		return gcd(b,a%b);
//	}
//}
//
//ll lcm(ll a,ll b){
//	return a / gcd(a,b) * b;
//} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值