Relatives 互质数个数

Relatives

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.
Input
There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.
Output
For each test case there should be single line of output answering the question posed above.
Sample Input
7
12
0
Sample Output
6
4
思路:
欧拉定理的小于N的互质数个数:
首先,可以先了解一下费马小定理:a^(p-1) ≡ 1 (mod p)
然后欧拉推广得出:a^(φ(n))=1(mod n),其中n,a都为正整数且互质,φ(n)是小于n的数中,与n互质的数的个数。
如果n为质数,则φ(n)=n-1;
否则找出n的所有质因子:b1,b2,b3……bi;
φ(n)=n(1-(1/b1))(1-(1/b2))……(1-(1/bi))

#include <iostream>
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
#include<stack>
#define INF 0x3f3f3f3f
#define me(a,b) memset(a,b,sizeof(a))
const int maxn=1e5+10;
using namespace std;

int main()
{
	int n,ans;
	while(scanf("%d",&n)!=EOF)
	{
		ans=n;
		if(n==0)
			break;
        for(int i=2;i*i<=n;i++)//n的因子只存在在小于等于根号n的数中
		{
			if(n%i==0)//找到因子
			{
				ans=ans/i*(i-1);//套用上面所讲公式,因怕数据太大,溢出,所以选择先除再乘
			}
			while(n%i==0)//去掉n中所有等于i的因子
				n=n/i;
		}
		if(n>1)//说明n是质数
			ans=ans/n*(n-1);
		printf("%d\n",ans);
	}
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值