Nim POJ - 2975 (Boutons定理 + 博弈)

Nim is a 2-player game featuring several piles of stones. Players alternate turns, and on his/her turn, a player’s move consists of removing one or more stones from any single pile. Play ends when all the stones have been removed, at which point the last player to have moved is declared the winner. Given a position in Nim, your task is to determine how many winning moves there are in that position.

A position in Nim is called “losing” if the first player to move from that position would lose if both sides played perfectly. A “winning move,” then, is a move that leaves the game in a losing position. There is a famous theorem that classifies all losing positions. Suppose a Nim position contains n piles having k1k2, …, kn stones respectively; in such a position, there are k1 + k2 + … + kn possible moves. We write each ki in binary (base 2). Then, the Nim position is losing if and only if, among all the ki’s, there are an even number of 1’s in each digit position. In other words, the Nim position is losing if and only if the xor of the ki’s is 0.

Consider the position with three piles given by k1 = 7, k2 = 11, and k3 = 13. In binary, these values are as follows:

 111
1011
1101
 

There are an odd number of 1’s among the rightmost digits, so this position is not losing. However, suppose k3 were changed to be 12. Then, there would be exactly two 1’s in each digit position, and thus, the Nim position would become losing. Since a winning move is any move that leaves the game in a losing position, it follows that removing one stone from the third pile is a winning move when k1 = 7, k2 = 11, and k3 = 13. In fact, there are exactly three winning moves from this position: namely removing one stone from any of the three piles.

Input

The input test file will contain multiple test cases, each of which begins with a line indicating the number of piles, 1 ≤ n ≤ 1000. On the next line, there are n positive integers, 1 ≤ ki ≤ 1, 000, 000, 000, indicating the number of stones in each pile. The end-of-file is marked by a test case with n = 0 and should not be processed.

Output

For each test case, write a single line with an integer indicating the number of winning moves from the given Nim position.

Sample Input
3
7 11 13
2
1000000000 1000000000
0
Sample Output
3
0

题意

有n堆石头,甲乙两个人轮流拿,每次从某堆石头中拿出至少一个。若轮到某人时无石可拿,此人输。

当甲存在必赢策略时,并不意味着他从任意一堆里选石头都能赢 , 而是说 , 甲通过取走某一堆的确定数量的石子  , 使得甲必赢。求甲可以选择的方法数。

1,先算出全部异或出来的值 , res ^= a[i];

2,res和每个值异或 , 如果小于该值则ans++ , res ^a[i] < a[i];

要想使该值异或为零 , 那么我们取走后的数字一定会和res 异或为0 , 如果res ^ a[i] >= a[i] , 那么这个数无法通过取走一个值使其变成大于其原本的数 , 因此这种情况不计。

注意:异或优先级低于关系运算符

下面代码

#include <stdio.h>
#include <iostream>
#include <cstring>
using namespace std;
int main()
{
	long long int n , ans , res , a[1005];
	while(~scanf("%lld" , &n) && n)
	{
		res = 0 ;
		ans = 0;
		for(int i = 0 ; i < n ; i++)
		{
			scanf("%lld" , &a[i]);
			res ^= a[i];
		}
		for(int i = 0 ; i < n ; i++)
		{
			if((res ^ a[i] ) < a[i])
			{
				ans++;
			}
		}
		printf("%lld\n" , ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值