HDU 4734 F(x) (数位DP)

F(x)

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Problem Description

For a decimal number x with n digits (AnAn-1An-2 ... A2A1), we define its weight as F(x) = An * 2n-1 + An-1 * 2n-2 + ... + A2 * 2 + A1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).

Input

The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 109)

Output

For every case,you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then output the answer.

Sample Input

3

0 100

1 10

5 100

Sample Output

Case #1: 1

Case #2: 2

Case #3: 13

 

思路:基础数位DP,记录状态的时候因为前缀sum会很大(1e9),所以dp数组开不出来,但是按题意F(x)最多也就5000不到,所以可以反向记录状态,因为sum>F(x)的我们return 0,所以DP数组内的状态是F(x)-sum就也可以记录了。

代码

#include<bits/stdc++.h>
using namespace std;

int dp[20][5005];///pos,allval-nowsum
int b[20];
int all;
int cal(int a){///求出F(a),allval
    if(a==0) return 0;
    int ans=cal(a/10);
    return ans*2+(a%10);
}

int dfs(int pos,int sum,bool limit){///sta=allval-sum;
    if(pos==-1) {
        return sum<=all;
    }
    if(sum>all) return 0;///如果此时sum已大于all,就没有继续遍历的必要了
    if(!limit&&dp[pos][all-sum]!=-1) return dp[pos][all-sum];
    int up=limit?b[pos]:9;
    int ans=0;
    for(int i=0;i<=up;i++) ans+=dfs(pos-1,sum+i*(1<<pos),limit&&i==b[pos]);
    if(!limit) dp[pos][all-sum]=ans;
    return ans;
}

int sol(int x){
    int pos=0;
    while(x){
        b[pos++]=x%10;
        x/=10;
    }
    return dfs(pos-1,0,true);
}


int main(){
    int T;
    scanf("%d",&T);
    int cas=0;
    memset(dp,-1,sizeof(dp));
    while(T--){
        int a,b;
        scanf("%d%d",&a,&b);
        all=cal(a);
        printf("Case #%d: %d\n",++cas,sol(b));
    }
}

参考博客:https://blog.csdn.net/wust_zzwh/article/details/52100392

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值