hdu 1150

 

Problem Description

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines. 

Input:

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.

Output:

The output should be one integer per line, which means the minimal times of restarting machine.

Sample Input

5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0

Sample Output

3

 题意: 两种机器各有不同的工作模式,每个任务都可以有两种机器中的某一个的工作模式解决,机器刚开始在0状态,问要两种机器要切换多少次状态可以完成所有工作。

以两种机器的不同状态作为二分图,问题就变成了需要二分图里的最少多少个点能把所有的边包括进去。这样就变成了求二分图的最小覆盖,而最小覆盖 = 最大匹配。证明: http://www.cppblog.com/abilitytao/archive/2009/09/02/95147.html

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn = 1e5+5;
struct Hungary {
	int n, m;				// 两个集合点的个数 
	int vis[maxn], link[maxn];
	vector <int> edge[maxn];
	
	void init(int n, int m)
	{
		this -> n = n;
		this -> m = m;
		memset(link, -1, sizeof(link));
		for(int i = 0;i <= n + m + 5;i ++)	
			edge[i].clear();
	}
	void addEdge(int s, int t)
	{
		edge[s].push_back(t);
		edge[t].push_back(s);
	}
	int find(int k)
	{
	    for(int i = 0;i < edge[k].size();i ++)
	    {
	        int t = edge[k][i];
	        if(vis[t] == 0)
	        {
	            vis[t] = 1;
	            if(link[t] == -1 || find(link[t]))
	            {
	                link[t] = k;
	                return 1;
	            }
	        }
	    }
	    return 0;
	}
	int maxmatch()
	{
	    int ans = 0;
	    for(int i = 1;i <= n;i ++)
	    {
	        memset(vis, 0, sizeof(vis));
	        if(find(i)) ans ++;
	    }
	    return ans;
	}
}Match; 

int main()
{
	int n, m, k;
	while(~scanf("%d", &n))
	{
		if(n == 0)
			break;
		scanf("%d%d", &m, &k);
		Match.init(n, m);
		for(int i = 0;i < k;i ++)
		{
			int a, b, c;
			scanf("%d%d%d", &a, &b, &c);
			Match.addEdge(b, c + n);
		}
		printf("%d\n", Match.maxmatch());
	}
    return 0;
}
 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值