1130 Infix Expression 中序遍历中缀表达括号的运用

1130 Infix Expression (25 分)

Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

data left_child right_child

where data is a string of no more than 10 characters, left_child and right_child are the indices of this node's left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by −1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.

infix1.JPGinfix2.JPG
Figure 1Figure 2

Output Specification:

For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.

Sample Input 1:

8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1

Sample Output 1:

(a+b)*(c*(-d))

Sample Input 2:

8
2.35 -1 -1
* 6 1
- -1 4
% 7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1

Sample Output 2:

(a*2.35)+(-(str%871))

本题题意 中序遍历输出对应结点 关键是()该怎么加

本题思路:

本题思路是当1. 结点是叶子结点时 ,就不用输出括号,
            2.  当为 -a 也就是左结点为空 ,右结点不为空输出 ()
            3.  当左右结点都为空 输出()
            最后结果输出可能(只有一个叶子结点时就不会有外())会出现 ( a+b )  去掉最外层的情况即可      

具体代码实现:

#include<iostream>
#include<string>
using namespace std;
/**
本题思路是当1. 结点是叶子结点时 ,就不用输出括号,
			2.  当为 -a 也就是左结点为空 ,右结点不为空输出 ()
			3.  当左右结点都为空 输出() 
			最后结果输出可能(只有一个叶子结点时就不会有外())会出现 ( a+b )  去掉最外层的情况即可 
			 
**/
struct Node{
	string data;
	int l, r;
}node[21];
int n;
bool isRoot[21];
//并不存在 a+ null这种格式 就是左不为-1 右子树为空的情况 
string inorder(int root){
	if(node[root].l == -1 && node[root].r == -1) return node[root].data;
	if(node[root].r != -1 && node[root].l == -1) return "(" + node[root].data + inorder(node[root].r) + ")"; //这种情况是 - a  
	if(node[root].l != -1 && node[root].r != -1) return "(" + inorder(node[root].l) + node[root].data + inorder(node[root].r) + ")"; 
}
int main(){
	int l, r, root = 0;
	scanf("%d", &n);
	fill(isRoot+1, isRoot+21, true); 
	for(int i = 1; i <= n; i++){
		cin >> node[i].data >> l >> r;
		node[i].l = l;
		node[i].r = r;
		if(l != -1)
			isRoot[l] = false;
		if(r != -1)
			isRoot[r] = false;
	}
	while(isRoot[root] == false) root++;
	string s = inorder(root);
	if(s[0] == '(') 
	//substr(i,j)从第 i位开始,截取长度为j的字符串 
	//从第一位开始(此时长度为s.size() - 1)将最后一位去掉,此时的长度为 s.size()-2. 
		s = s.substr(1, s.size() - 2); 
	cout<<s<<endl;
	
	return 0;
} 

 

  • 0
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值