1052 Linked List Sorting(链表排序)

1052 Linked List Sorting (25 分)

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (<10​5​​) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [−10​5​​,10​5​​], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:

5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:

5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

/**
本题题意: 按从小到大 排序链表结点 (只不过结点的起点 , 终点 也需要重新相连)
遇到的问题:
1.注意无效结点
2.最后输入格式中的段错误
思路:
     1.结点的起点不会发生改变, 终点就是排好序后的 下一个结点的起点,
     2.用一个结构体 Node 类型 数组 a 存放输入的 起点, 值, 终点 (其中a[i]的下标是代表该点的起点, 根据题意要求数组容量开到 1e5 + 5
     3.本题的关键就是 给定的结点中存在无效结点, (也就是从开始位置能够遍历出来的节点,这判断无效节点是个坑,) 通过给定的start地址
     将可以联通的结点放入b数组
     4第二个坑就是在最后输出时 要作一个判空处理, 当start地址为 - 1时 直接输出 0 -1, 
**/

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
const int maxsize = 1e5 + 5;
struct Node{
	int ad, data, next;  //next 与 start 是有用的, 因为 存在着无用的点(就是未连接的点) ;
//	bool flag;
};

vector<Node> a, b;
bool cmp(Node a, Node b){
	return a.data < b.data;
}
int main(){
	int start, n, cnt = 0;
	scanf("%d%d", &n, &start);
	a.resize(maxsize); // 不要将这个和push_back组合使用 
	int ad, key, next;
	for(int i = 0; i < n; i++){
		scanf("%d%d%d", &ad, &key, &next);
//		a[ad].ad = ad; a[ad].data = key; a[ad].next = next;
		a[ad] = {ad, key, next};
	}
	for(int i = start; i != -1; i = a[i].next){
//		cnt++;
		b.push_back(a[i]);
//		a[start].flag = true;
	}
	sort(b.begin(), b.end(), cmp); //a.end() 就最后一个元素的后一个元素 
	if(start == -1){
	 	printf("0 -1\n");
	}else{
//		printf("%d %05d\n", b.size(), b[0].ad);
//		for(int i = 0; i < b.size(); i++){
//			printf("%05d %d ", b[i].ad, b[i].data);
//			if(i != b.size() - 1)
//				printf("%05d\n", b[i + 1].ad);
//			else
//				printf("-1\n");
//		}
//		printf("%d %05d\n", b.size(), b[0].ad); //此处的size 是b数组的size(因为存在无效结点) 
//		for(int i = 0; i <= b.size() - 2; i++){
//			printf("%05d %d %05d\n", b[i].ad, b[i].data, b[i + 1].ad);
//		}   
//		printf("%05d %d -1\n", b[b.size() - 1].ad, b[b.size() - 1].data);  // 这种写法在没有判断空的情况会出现越界错误 
		printf("%d %05d\n", b.size(), b[0].ad); //此处的size 是b数组的size(因为存在无效结点) 
		for(int i = 0; i < b.size() ; i++){
			if(i != b.size() - 1){
				printf("%05d %d %05d\n", b[i].ad, b[i].data, b[i + 1].ad);
			}else{
				printf("%05d %d -1\n", b[i].ad, b[i].data);  // 写在外面单独判断会出现断错误。。 
			}
		}   
	}
	
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值