1153 Decode Registration Card of PAT (25 分)(排序题)(字符串的处理)

1153 Decode Registration Card of PAT (25 分)

A registration card number of PAT consists of 4 parts:

  • the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
  • the 2nd - 4th digits are the test site number, ranged from 101 to 999;
  • the 5th - 10th digits give the test date, in the form of yymmdd;
  • finally the 11th - 13th digits are the testee's number, ranged from 000 to 999.

Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤10​4​​) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner's score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

  • Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
  • Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
  • Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.

Output Specification:

For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

  • for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
  • for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
  • for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt's, or in increasing order of site numbers if there is a tie of Nt.

If the result of a query is empty, simply print NA.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

/**
本题题意 就是给定n个学生的信息, 包括学生的id, 和 分数,
其中id中第一个数字表示考试的等级, 第2个数字至第4个数字表示
        第5个数字到第9个数字表示
再给定m个条件,
每个条件的类型type可以为 1 , 2 ,3(分别表示对学生id的三种情况进行处理)
本题注意的地方:
    用到
本题思路:
    设定一个struct Node数组将学生的信息放入数组中
    通过substr对学生的id进行分隔处理
    通过sort函数完成对题意要求的处理
    对于type = 3 时,要输出位置和数量
    将这两个信息用map保存,因为要对它们排序, 因此将它们放入vector({string, int})集合中
    遍历map时, 是for(auto it : m) it->frist, it->second;//并没有 *it->first

    本题要用 unordered_map 否则有测试数据会超时。
**/

使用stirng字符串方法 substr 处理代码可以化简很多代码:

#include<iostream>
#include<algorithm>
#include<vector>
#include<unordered_map> 
using namespace std;
const int maxsize = 1e4 + 5;
struct Node{
	string id;
	int score;
}a[maxsize];
bool cmp1(Node &a, Node &b){ //运用 地址引用符号更加快捷。 
	if(a.score != b.score)
		return a.score > b.score;
	else
		return a.id  < b.id;
}
int n, m;
vector<Node> res;
int main(){
	string id, s;
	int score, type;
	scanf("%d%d", &n, &m);
	for(int i = 0; i < n; i++){
		cin >> id;
		scanf(" %d", &score);
		a[i].id = id;
		a[i].score = score;
	}
	for(int i = 1; i <= m; i++){
		scanf("%d", &type);
		cin >> s;
		printf("Case %d: %d %s\n", i, type, s.c_str());
		if(type == 1){
			for(int j = 0; j < n; j++){
				if(a[j].id[0] == s[0]){
					res.push_back(a[j]);
				}	
			}
		}else if(type == 2){
			int num = 0, sum = 0;
			for(int i = 0; i < n; i++){
				if(a[i].id.substr(1, 3) == s){
					num++;
					sum += a[i].score;
				}
			}
			if(num == 0)
				printf("NA\n");
			else
				printf("%d %d\n", num, sum);
			continue;
		}else if(type == 3){
			unordered_map<string, int> m;
			for(int i = 0; i < n; i++){
				if(a[i].id.substr(4, 6) == s){
					m[a[i].id.substr(1, 3)]++;
				}
			}
			for(auto it : m){
				res.push_back({it.first, it.second});
			} 
		}
		if(res.size() == 0)
			printf("NA\n");
		else{
			sort(res.begin(), res.end(), cmp1);
			for(int i = 0; i < res.size(); i++){
				printf("%s %d\n", res[i].id.c_str(), res[i].score);
			}
			res.clear();	
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值