1089 Insert or Merge (25 分) (判断插入排序,分治排序)

1089 Insert or Merge (25 分)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6

/**
本题题意考察 给定序列n 以及最终序列 target
需要知道 最终序列 是插入排序 或者是 分治排序? , 并输出 它们 对应排序 的下一步序列
思路:
     先对原始序列作插入排序 , 观察序列是否与目标序列相等
     相等则输出插入排序下一步
     否则是 分治排序
     分治排序相等: 用sort函数进行分治排序, 直到 序列与目标序列相同
**/

 

#include<iostream>
#include<algorithm>
using namespace std;
const int maxsize = 120;
bool isRes = false;
int n;
bool isSame(int temp[], int target[]){
	for(int i = 0; i < n; i++){
		if(temp[i] != target[i])
			return false;
	}
	return true;
}
void showArr(int a[]){
	for(int i = 0; i < n; i++){
		printf("%d", a[i]); 
		if(i != n - 1)
			printf(" ");
	}
}
int main(){
	int  a[maxsize], target[maxsize], tempArr[maxsize];
	scanf("%d", &n);
	for(int i = 0; i < n; i++){
		scanf("%d", &a[i]);
		tempArr[i] = a[i];
	}
	for(int i = 0; i < n; i++){
		scanf("%d", &target[i]);
	}
	//插入排序
	for(int i = 1; i < n; i++){ //初始序列不参与排序, 此处 i = 1, 如果为1 测试点2不能通过 
		if(i != 1 && isSame(tempArr, target))
			isRes= true;
		int temp = tempArr[i], j = i;
		while(j > 0 && tempArr[j - 1] > temp){ //此步 不能写为 tempArr[j - 1] > temp[j] temp[j] 并不是 temp ,循环遍历完后 才会更替 
			tempArr[j] = tempArr[j - 1];
			j--;
		}
		tempArr[j] = temp;
		if(isRes == true){
			printf("Insertion Sort\n");
			showArr(tempArr);
			return 0;
		}
	}
	//分治排序 
	printf("Merge Sort\n"); 
	for(int i = 2; i / 2 <= n; i *= 2){ //分治算法此步需要注意步长的范围 (
		if(i != 2 && isSame(a, target)){
			isRes = true;
		}
		for(int j = 0; j < n; j += i){
			sort(a + j, a + min(j + i, n));	//此步取最小的一个 , 防止最后一组数据
											//不够步长, 导致下标越界		
		}
		if(isRes){
			showArr(a);
			return 0;
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值