HDU 2602

1 篇文章 0 订阅

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input

 The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone. 

Output

 One integer per line representing the maximum of the total value (this number will be less than 231). 

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14

讲解

由于本人刚接触dp这个算法,所以就十分无法理解状态转移方程如何得出,是看了很ac的代码以后才算有点感觉。
下面是状态转移方程

 

 for(i = 1; i <= n; i++){
    for(j = v; j >= volume[i]; --j){
        dp[j] = max(dp[j - volume[i]] + value[i], dp[j]);
    }            
}

接下来已上面的测试数据为例,把每一步执行结果以表格的形式表示出来,希望能让你对这道题有所收获。

列为dp数组,行为遍历的五次。
 

 12345678910
10000111111
20002222233
30033335555
40444777799
5559991212121214

下面是我的代码:

#include<cstdio>
int dp[1010];
int value[1010];
int volume[1010];
int max(int a,int b){
    if(a < b)
        return b;
    return a;
}
int main(){
    int t,n,v,i,j;
    scanf("%d",&t);
    while(t-- != 0){
        scanf("%d %d",&n,&v);
        for(i = 1; i <= n; i++){
            scanf("%d",&value[i]);
        }
        for(i = 1; i <= n; i++){
            scanf("%d",&volume[i]);
        }
        for(i = 0; i <= v; i++){
            dp[i] = 0;
        }
        for(i = 1; i <= n; i++){
            for(j = v; j >= volume[i]; --j){
                dp[j] = max(dp[j - volume[i]] + value[i], dp[j]);
            }
        }
        printf("%d\n",dp[v]);
    }
    return 0 ;
}

 

 

 

 

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值