51Nod 2176 ProjectEuler 3 c/c++题解

题目描述

13195 的质因数有 5, 7, 13 和 29。
输入n,输出n最大的质因数。
输入
输入第一行组数T,
接下来T行,每行一个整数n。
(1 <= T <= 20)
(2 <= n <= 1000000000000)
输出
对于每组数据,输出一个数,表示n最大的质因数。
输入样例
3
10
17
600851475143
输出样例
5
17
6857

题解:

用了一个求质因数的模板,然后直接输出最后一个质因数即是最大的质因数:

void get_div(ll x)//分解质因数
{
	for(ll i = 2; i <= (ll)sqrt(x); i++)
	{
		while(x % i == 0)
		{
			arr.push_back(i);
			x /= i;
		}
	}
	if(x != 1)
	{
		arr.push_back(x);
	}
}

代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <climits>
#include <cstring>
#include <string>
#include <algorithm>
#include <vector>
#include <deque>
#include <list>
#include <utility>
#include <set>
#include <map>
#include <stack>
#include <queue>
#include <bitset>
#include <iterator>
using namespace std;

typedef long long ll;
const int inf = 0x3f3f3f3f;
const ll  INF = 0x3f3f3f3f3f3f3f3f;
const double PI = acos(-1.0);
const double E = exp(1.0);
const int MOD = 1e9+7;
const int MAX = 1e5+5;
int t;
ll n;

vector <ll> arr;
void get_div(ll x)//分解质因数
{
	for(ll i = 2; i <= (ll)sqrt(x); i++)
	{
		while(x % i == 0)
		{
			arr.push_back(i);
			x /= i;
		}
	}
	if(x != 1)
	{
		arr.push_back(x);
	}
}

int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    cout.tie(0);

    cin >> t;
    while(t--)
    {
        cin >> n;
        get_div(n);
        cout << arr[arr.size()-1] << endl;
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值