51Nod 2172 ProjectEuler 6 c/c++题解

[题目描述[(http://www.51nod.com/Challenge/Problem.html#problemId=2172)

前10个正整数的平方和是
12+22+⋯+102=385
前10个正整数和的平方是
(1+2+⋯+10)2=3025
和的平方减去平方和是3025 - 385 = 2640。
输入n,求前n个正整数和的平方 减去 平方和。
输入
输入第一行组数T,
接下来T行,每行一个整数n。
(1 <= T <= 100)
(1 <= N <= 100)
输出
对于每组数据,输出一个数,表示和的平方减去平方和。
输入样例
3
3
10
100
输出样例
22
2640
25164150

代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <climits>
#include <cstring>
#include <string>
#include <algorithm>
#include <vector>
#include <deque>
#include <list>
#include <utility>
#include <set>
#include <map>
#include <stack>
#include <queue>
#include <bitset>
#include <iterator>
using namespace std;

typedef long long ll;
const int inf = 0x3f3f3f3f;
const ll  INF = 0x3f3f3f3f3f3f3f3f;
const double PI = acos(-1.0);
const double E = exp(1.0);
const int MOD = 1e9+7;
const int MAX = 1e5+5;
int n;

ll Square_Sum(int n)
{
    ll res = 0;
    for(int i = 1; i <= n; i++)
    {
        res += i*i;
    }
    return res;
}

ll Sum_Square(int n)
{
    ll res = n + (n*(n-1))/2;
    res *= res;
    return res;
}

int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    cout.tie(0);

    int t;
    cin >> t;
    while(t--)
    {
        int n;
        cin >> n;
        cout << Sum_Square(n) - Square_Sum(n) << endl;
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值