51Nod 2164 ProjectEuler 9 c/c++题解

题目描述

勾股数是满足a < b < c,且 a2+b2=c2 的三元组(a, b, c)。
输入n,计算是否存在勾股数(a, b, c)满足a + b + c = n。
如果有多组,求所有满足条件的勾股数(a, b, c)中,abc的最大值。输入保证有解。
输入
输入第一行组数T,
接下来T行,每行一个整数n。
(1 <= T <= 190)
(1 <= N <= 1000)
输出
对于每组数据,输出最大可能的abc,输入保证有解。
输入样例
2
12
1000
输出样例
60
31875000

代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <climits>
#include <cstring>
#include <string>
#include <algorithm>
#include <vector>
#include <deque>
#include <list>
#include <utility>
#include <set>
#include <map>
#include <stack>
#include <queue>
#include <bitset>
#include <iterator>
using namespace std;

typedef long long ll;
const int inf = 0x3f3f3f3f;
const ll  INF = 0x3f3f3f3f3f3f3f3f;
const double PI = acos(-1.0);
const double E = exp(1.0);
const int MOD = 1e9+7;
const int MAX = 1e5+5;
int t,n;

int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    cout.tie(0);

    cin >> t;
    while(t--)
    {
        cin >> n;
        int max_sum = -inf;
        for(int a = 1; a <= n; a++)
        {
            for(int b = a+1; b <= n; b++)
            {
                int cc = a*a + b*b;
                if(a + b + sqrt(cc) == n)
                {
                    if(a*b*sqrt(cc) > max_sum)
                    {
                        max_sum = a*b*sqrt(cc) ;
                    }
                }
            }
        }
        cout << max_sum << endl;
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值