动态规划_POJ1141(线性DP) Brackets Sequence(合法括号序列)

Brackets Sequence

原题链接:http://poj.org/problem?id=1141
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 34891 Accepted: 10095 Special Judge
Description

Let us define a regular brackets sequence in the following way:

  1. Empty sequence is a regular sequence.
  2. If S is a regular sequence, then (S) and [S] are both regular sequences.
  3. If A and B are regular sequences, then AB is a regular sequence.

For example, all of the following sequences of characters are regular brackets sequences:

(), [], (()), ([]), ()[], ()[()]

And all of the following character sequences are not:

(, [, ), )(, ([)], ([(]

Some sequence of characters ‘(’, ‘)’, ‘[’, and ‘]’ is given. You are to find the shortest possible regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string a1 a2 … an is called a subsequence of the string b1 b2 … bm, if there exist such indices 1 = i1 < i2 < … < in = m, that aj = bij for all 1 = j = n.
Input

The input file contains at most 100 brackets (characters ‘(’, ‘)’, ‘[’ and ‘]’) that are situated on a single line without any other characters among them.
Output

Write to the output file a single line that contains some regular brackets sequence that has the minimal possible length and contains the given sequence as a subsequence.
Sample Input

([(]
Sample Output

()[()]
Source

Northeastern Europe 2001

题解:
设阶段r为子序列的长度(1<=r<=n),状态i为当前子序列的首指针(0<=i<=n-r+1)。由当前子序列的首指针i和长度可以得出尾指针j = i+r-1。当前子序列si……sj需要添加的最小字符数为dp[i,j]。显然当子序列长度为1时,dp[i,i] = 1(0<=i<strlen(s))。问题是,当子序列长度大于1时,怎么办?
若(si =’ [ ’ && sj =’ ] ')||(si = ’ ( ’ && sj = ’ ) ’ ),则si……sj需要添加的最少字符数取决于s(i+1)……s(j-1),即dp[i.j] = dp[i+1,j-1];否则需要二分si……sj,决策产生最少添加字符串的中间指针 k(i<=k<j),即dp[i,j] = min(dp[i,k] + dp[k+1][j])
我们通过记忆表path[ ][ ]存储所有子问题的解:
path[i][j]=-1 si与sj括号配对
=左右子序列的最佳划分位置k 否则

AC代码:

#include<cstdio>
#include<cstring>
const int N = 100;
char str[N];
int dp[N][N];
int path[N][N];

void oprint(int i,int j)
{
    if(i>j)
    return;
    if(i == j)
    {
        if(str[i] == '[' || str[i] == ']')
            printf("[]");
        else
            printf("()");
        return;
    }
    if(path[i][j] == -1)
    {
        if(i+1==j)
            printf("%c%c",str[i],str[j]);
        else
        {
            printf("%c",str[i]);
            oprint(i+1,j-1);
            printf("%c",str[j]);
        }
    }
    else
    {
        oprint(i,path[i][j]);
        oprint(path[i][j] + 1,j);
    }
}

int main()
{
    while(gets(str))
    {
        int n = strlen(str);
        if(n==0)
        {
            printf("\n");
            return 0;
        }
        memset(dp,0,sizeof(dp));
        for(int r=1;r<=n;r++)
        {
            for(int i=0;i<n-r+1;i++)
            {
                int j = i+r-1;
                if(i==j)
                {
                    dp[i][j] = 1;
                }
                else
                {
                    dp[i][j] = 0x3f3f3f3f;
                    if((str[i] == '(' && str[j] ==')') ||(str[i] =='[' && str[j] ==']'))
                    {
                        if(i+1==j)
                            dp[i][j] = 0;
                        else
                        {
                            if(dp[i][j] > dp[i+1][j-1])
                                dp[i][j] = dp[i+1][j-1];
                        }
                        path[i][j] = -1;
                    }
                    for(int k=i; k<j ;k++)
                    {
                        if(dp[i][j] >dp[i][k] + dp[k+1][j])
                        {
                            dp[i][j] = dp[i][k] + dp[k+1][j];
                            path[i][j] = k;
                        }
                    }
                }
            }
        }
        oprint(0,n-1);
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值