POJ 3311 Hie with the Pie //TSP旅行商问题,弗洛伊德,状压dp

44 篇文章 0 订阅

POJ 3311 Hie with the Pie  //TSP旅行商问题,弗洛伊德,状压dp

http://poj.org/problem?id=3311

Hie with the Pie

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 10935 Accepted: 5802

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8

题意遍历所有点(一个点可以遍历多次),再回到起点的最小路程 。(据说搜索可过,不考虑搜索( 复杂度O(n!) )。)

反正怎么也要用到状态压缩,每个点遍历或者不遍历用0or1表示,二进制存起来。

dp[i][j]表示当前二进制状态是i,在点j的最短路程。首先预处理一个mp[][],用弗洛伊德跑出最短路径。

一开始的想法是,枚举n次每一次到的点,然后更新dp[][]。

dp[k+(1<<(j-1))][j]=min(dp[k+(1<<(j-1))][j],dp[k][x]+mp[x][j]);

复杂度是n^3*2^n。//各种稀疏剪枝就其实复杂度会更低

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<climits>
using namespace std;
#define LL long long
int n;
int mp[15][15];
int dp[1<<12][15];//987654321 1111111111
void init(){
	for(int i=1;i<=(1<<n);i++){
		for(int j=1;j<=n;j++)
			dp[i][j]=INT_MAX/2;
	}
	dp[1][1]=0;
	for(int i=1;i<=n;i++)
		for(int j=1;j<=n;j++)
			scanf("%d",&mp[i][j]);
	for(int i=1;i<=n;i++){
		for(int j=1;j<=n;j++){
			for(int k=1;k<=n;k++){
				mp[i][j]=min(mp[i][j],mp[i][k]+mp[k][j]);
			}
		}
	}
}
int main(){
	while(cin>>n){
		if(n==0) break;
		n++;
		init();
		for(int i=1;i<=n;i++){
			for(int j=1;j<=n;j++){
				for(int k=1;k<(1<<n);k++){
                    if((k>>(j-1))&1==1)continue; //要到的点已经走过了
                    int vised=0;int kk=k;
                    while(kk){if(kk%2)vised++;kk=kk/2;}   //计算走过点的数量
                    if(vised!=i) continue; //因为是加入第i个点,
					for(int x=1;x<=n;x++){
						dp[k+(1<<(j-1))][j]=min(dp[k+(1<<(j-1))][j],dp[k][x]+mp[x][j]);
						//cout<<k+(1<<(j-1))<<' '<<j<<' '<<dp[k+(1<<(j-1))][j]<<endl;
					}
				}
			}
		}
		int ans=INT_MAX;
		for(int i=1;i<=n;i++)
			ans=min(ans,dp[(1<<n)-1][i]+mp[i][1]);
		cout<<ans<<endl;
	}
	return 0;
}

然后发现i其实在循环里没有出现过,发现dp[i][j]可以由前面的状态转移过来。

用每一个点更新dp[][],但是要更新的次序(二进制状态和点)不能变

要更新当前二进制状态为i,在的点为j,需要已知更小的二进制状态的状态。

如果先更一个二进制状态下对应每个点的值,那么会造成很多数据没有更新,因为之前的数据不存在,为INT_MAX。(画出表就可以发现)

复杂度O(n^2*2^n)

优化后代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<climits>
using namespace std;
#define LL long long
int n;
int mp[15][15];
int dp[1<<12][15];//987654321 1111111111 当前二进制,在i位置
void init(){
	for(int i=1;i<=(1<<n);i++){
		for(int j=1;j<=n;j++)
			dp[i][j]=INT_MAX/2;
	}
	dp[1][1]=0; //初始起点
	for(int i=1;i<=n;i++)
		for(int j=1;j<=n;j++)
			scanf("%d",&mp[i][j]);
	for(int i=1;i<=n;i++){
		for(int j=1;j<=n;j++){
			for(int k=1;k<=n;k++){
				mp[i][j]=min(mp[i][j],mp[i][k]+mp[k][j]);
			}
		}
	}
}
int main(){
	while(cin>>n){
		if(n==0) break;
		n++;
		init();
		for(int j=1;j<(1<<(n));j++){ //优先更新二进制状态
			for(int i=1;i<=n;i++){ //再更新点
                int b=1<<(i-1);
				if(j&b){ //走过了i点
					for(int k=1;k<=n;k++) {
						if((j&(1<<(k-1)))&&i!=k)  //由k点走向i点,k对应二进制要为1,i不能等于k
						dp[j][i]=min(dp[j][i],dp[j^b][k]+mp[k][i]);
					}
				}
			}
		}
		int ans=INT_MAX;
		for(int i=2;i<=n;i++)
			ans=min(ans,dp[(1<<n)-1][i]+mp[i][1]);
		cout<<ans<<endl;
	}
	return 0;
}

居然懵逼了一晚上,很焦灼。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值