poj 3169 Layout //差分约束(最短路(判负环 + 负边))

http://poj.org/problem?id=3169

差分约束(最短路(判负环 + 负边))

 

Layout

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16237 Accepted: 7795

Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). 

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. 

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD. 

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart. 

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample: 

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. 

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

Source

USACO 2005 December Gold

 题意:一行依次站编号为1-n的牛,其中对有些牛的距离要求大于ML或者小于MD,求1和n的最大距离。

差分约束。

利用图构造不等式的约束条件,然后1-n的距离就是答案(因为要满足所有不等式)。d[n]-d[1]<=x

如果有负环说明无解, 如果不能到达,说明答案无限大。

具体如下(挑战程序设计)。

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<climits>
#include<cmath>
#include<vector>
#include<cstring>
#include<queue>
using namespace std;
#define mod 1000000007
const int max_n=1005;
struct no{int to,d;};
vector<no> g[max_n];
int d[max_n],inq[max_n];
int vis[max_n];
int spfa(int s,int t,int n){    //记得初始化
    //如果入队次数大于n+1,那么有负环(自己手写)

    queue<int>q;
    q.push(s),d[s]=0,inq[s]=1;vis[s]++;
    while(!q.empty()){
        int now=q.front();
        for(int i=0;i<(int)g[now].size();i++){
            int v=g[now][i].to;
            if(d[v]>d[now]+g[now][i].d){ //松弛操作
                d[v]=d[now]+g[now][i].d;
                if(inq[v])continue;
                inq[v]=1;
                q.push(v);
                vis[v]++;
                if(vis[v]>n+1) return -1;
            }
        }
        q.pop();
        inq[now]=0;
    }
    if(d[t]==INT_MAX/2) return -2;
    return d[t];
}

int main(){
    ios::sync_with_stdio(false);cin.tie(0);
    int n,ml,md;cin>>n>>ml>>md;
    for(int i=1;i<n;i++) g[i+1].push_back((no){i,0});
    while(ml--){
        int u,v,c;
        cin>>u>>v>>c;
        g[u].push_back((no){v,c});
    }
    while(md--){
        int u,v,c;
        cin>>u>>v>>c;
        g[v].push_back((no){u,-c});
    }
    for(int i=0;i<=n;i++) d[i]=INT_MAX/2;
    int ans=spfa(1,n,n);
    cout<<ans;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值