poj 3368 Frequent values //线段树合并

poj 3368 Frequent values //线段树合并

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 23590 Accepted: 8262

Description

You are given a sequence of n integers a1 , a2 , ... , an in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers ai , ... , aj.

Input

The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains n integers a1 , ... , an (-100000 ≤ ai ≤ 100000, for each i ∈ {1, ..., n}) separated by spaces. You can assume that for each i ∈ {1, ..., n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the 
query.

The last test case is followed by a line containing a single 0.

Output

For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.

Sample Input

10 3
-1 -1 1 1 1 1 3 10 10 10
2 3
1 10
5 10
0

Sample Output

1
4
3

题意:给q个询问,求一段区间的最多数出现的次数。

预处理相同能左右延展到的长度,

build时pushup两个子区间和两个子区间的连接处。

询问时,对于连接处加以判断,可能一个区间更新re多次,这不影响。

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <climits>
using namespace std;
#define LL long long
#define mod 1000000007
#define MAXN 100005
int a[MAXN],mx[MAXN<<2];
int dpl[MAXN],dpr[MAXN];

void build(int l,int r,int root){
    if(l==r){
        mx[root]=1;
        return;
    }
    int m=(l+r)>>1;
    build(l,m,root<<1);
    build(m+1,r,root<<1|1);
    mx[root]=max(mx[root<<1],mx[root<<1|1]);
    if(m>=l&&m+1<=r){
        int ll=min(m-l+1,dpl[m]);int rr=min(r-(m+1)+1,dpr[m+1]);
        if(a[m]==a[m+1])mx[root]=max(mx[root],ll+rr);
    }
}

int querymx(int L,int R,int l,int r,int root){
    if(l>=L&&r<=R)
        return mx[root];
    int m=(l+r)>>1;
    int re=INT_MIN;
    if(m>=L) re=max(re,querymx(L,R,l,m,root<<1));
    if(m<R)  re=max(re,querymx(L,R,m+1,r,root<<1|1));
    if(m>=L&&m+1<=R){
        int ll=min(m-L+1,dpl[m]);int rr=min(R-(m+1)+1,dpr[m+1]);
        if(a[m]==a[m+1])re=max(re,ll+rr);
    }
    return re;
}
int main(){
    int n,q;
    while(scanf("%d",&n)!=EOF&&n!=0){
        scanf("%d",&q);
        for(int i=1;i<=n;i++)scanf("%d",&a[i]);
        dpl[1]=1;
        for(int i=2;i<=n;i++){
            if(a[i]==a[i-1])dpl[i]=dpl[i-1]+1;
            else dpl[i]=1;
        }
        dpr[n]=1;
        for(int i=n-1;i>=1;i--){
            if(a[i]==a[i+1])dpr[i]=dpr[i+1]+1;
            else dpr[i]=1;
        }
        build(1,n,1);
        while(q--){
            int a,b;
            scanf("%d%d",&a,&b);
            printf("%d\n",querymx(a,b,1,n,1));
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值